View Single Post
  #1  
Old 30th April 2008, 14:46
PhilyWisk PhilyWisk is offline
Junior Member
 
Join Date: Feb 2008
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Default Apache2 undefined symbol: gzopen64

Hi, I have had the following problem twice now.

The first time I assumed it was because I installed webmin on top of ISPconfig but this time I have kept the install clean and not tried webmin.

I was logged in through ssh and restarted apache2:

Code:
root@localhost:~# /etc/init.d/apache2 restart
* Restarting web server apache2
* We failed to correctly shutdown apache, so we're now killing all running apache processes. This is almost certainly suboptimal, so please make sure your system is working as you'd expect now!
apache2: Syntax error on line 183 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
                                                                         [fail]
I followed the Perfect Server on Ubuntu howto exactly.

Please note I have solved this solution. Using advice from https://bugs.launchpad.net/ubuntu/+s...l2/+bug/151045
(i.e I removed /usr/local/lib/libz* and restarted apache2) but I was interested to know what the issue was.
Reply With Quote
Sponsored Links