View Single Post
  #5  
Old 19th April 2008, 20:53
debian-lover debian-lover is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 13
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I did followed the steps listed in the official ISPConfig documentation to create a CSR. Ok, here's what I did:

- Enabled SSL Checkbox
- In the SSL Tab, filled all the information in text-boxes
- In the drop down, selected "Create Certificate"
- Wait for a minute
- In the drop down, selected "Save Certificate"
- Restarted apache and everything working fine (I can access https:// with the popup).

Now, to replace the self-signed cert with trusted cert.
- In the SSL tab, copied the "SSL Request" and sent it to CA.
- They gave me the certificate, and I relaced the default "SSL Certificate" with the one CA gave me.
- "Save certificate"
- Restarted apache, and it stopped working.

As I said, I've tried this with two different CAs. One of them required the SSLCertificateChainFile, I uploaded the chain file and entered the required line the "Apache Directives (Optional)." Both of them give the same error.

Also, I am still confused about the IPs. Should I get more public IPs or Private IPs?

Sorry for being a pain. I am working on it as hard as I can. Thanks for your time.
Reply With Quote