View Single Post
  #3  
Old 19th April 2008, 11:28
debian-lover debian-lover is offline
HowtoForge Supporter
 
Join Date: Mar 2008
Posts: 13
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Yes till, it works fine with the self-signed certificate, but when I install a trusted certificate, apache stops working and doesn't restart until I delete the new certificate. I've tried two different certificates, from comodo and rapidssl. Both give the same error that doesn't let the apache to restart.

Code:
[Sat Apr 19 01:18:49 2008] [error] Unable to configure RSA server private key
[Sat Apr 19 01:18:49 2008] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
I googled for this error and found this
Quote:
View the certificate modulus using the following command:

openssl x509 -noout -text -in certfile -modulus


View the key using the following command:

openssl rsa -noout -text -in keyfile -modulus


Verify the following:
Verify that the certificate and private key is saved in Notepad and that it has no trailing spaces.
The "modulus" and "public exponent" portions in the key and the certificate must match exactly.
Make sure you aren't using the default server.key file.
You should also check the httpd.conf file to make sure that the directives are pointing to the correct private key and certificate.


If they do not match, you will have to reissue your certificate

From: http://www.entrust.net/knowledge-bas...te.cfm?tn=5892
They, indeed, match in my case. I can't figure out where the problem is. Any Idea?
Reply With Quote