View Single Post
  #3  
Old 21st March 2008, 18:11
sebastienp sebastienp is offline
Junior Member
 
Join Date: Mar 2008
Posts: 16
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Falco,
Thanks for your reply and support.

I used this URL : http://www.howtoforge.com/pxe_booting_debian. I followed the howto stricly, except name and IP address.

Here are my configuration files :
/pxeroot/etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback
# The primary network interface
auto eth0
iface eth0 inet dhcp

/pxeroot/etc/hosts
127.0.0.1 localhost debian
# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

/pxeroot/etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>
/dev/ram0 / ext2 defaults 0 0
proc /proc proc defaults 0 1
tmpfs /tmp tmpfs defaults 0 1

/etc/dhcp3/dhcpd.conf
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.100 192.168.1.105;
option subnet-mask 255.255.255.0;
filename "pxelinux.0";
next-server 192.168.1.9;
option root-path "192.168.1.9:/pxeroot";
option broadcast-address 192.168.1.255;
}

A pxe client can boot over the network, BUT the main issue is that NFS never mounts.
I have the same error again and again :
nfs, server not responding, time out, then still trying.

Talking with olivier2b about this, he suggested to modify this file
/pxeroot/etc/initramfs-tools/initramfs.conf
with BOOT=nfs instead of BOOT=local = no change same error.
I also tried with NFSROOT=auto and 192.168.1.9:/pxeroot, no change.

Then he suggested to add host in hosts.allow files. Mine are like that :
ALL:ALL (I tried with portmap:ALL and mountd:ALL, successless).

Logs are :
/var/log/messages
Mar 21 16:55:59 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:55:59 debian dhcpd: DHCPREQUEST for 192.168.1.122 (192.168.1.10) from 00:0d:60:8e:72:84 via eth0: unknown lease 192.168.1.122.
Mar 21 16:56:00 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:15 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:15 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:17 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:17 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0

/var/log/syslog
Mar 21 16:55:59 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:55:59 debian dhcpd: DHCPREQUEST for 192.168.1.122 (192.168.1.10) from 00:0d:60:8e:72:84 via eth0: unknown lease 192.168.1.122.
Mar 21 16:56:00 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:15 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:15 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:17 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:17 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:17 debian in.tftpd[4037]: tftp: client does not accept options
Mar 21 16:56:27 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:27 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:28 debian mountd[2074]: authenticated mount request from 192.168.1.105:835 for /pxeroot (/pxeroot)
Mar 21 16:56:50 debian dhcpd: DHCPDISCOVER from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:50 debian dhcpd: DHCPOFFER on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:50 debian dhcpd: DHCPREQUEST for 192.168.1.105 (192.168.1.9) from 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:50 debian dhcpd: DHCPACK on 192.168.1.105 to 00:0d:60:8e:72:84 via eth0
Mar 21 16:56:50 debian mountd[2074]: authenticated mount request from 192.168.1.105:877 for /pxeroot (/pxeroot)

/var/log/daemon.log
Mar 21 16:56:17 debian in.tftpd[4037]: tftp: client does not accept options
Mar 21 16:56:28 debian mountd[2074]: authenticated mount request from 192.168.1.105:835 for /pxeroot (/pxeroot)
Mar 21 16:56:50 debian mountd[2074]: authenticated mount request from 192.168.1.105:877 for /pxeroot (/pxeroot)

I can't figure out what went wrong, but I did read a lot over Google regarding this kind of error.
I tried several solutions :
-change cable = no change same error;
-change switch = no change same error;
-I used several PC as clients, with different NIC = no change same error;
-change tftp server by replacing tftpd-hpa by atftpd = no change same error;
-did several changes over config files from my researches = no change same error;

NFS is working, I can mount and access it with mount command...

I did successfully set a platform to install OS by pxe boot, it works perfectly !

What I want to do is booting over the network with PXE to load a custom debian install to perform hardware inventory (with OCS client), partitionning (with partimage) and hard drive wiping (with wipe).

Many thanks for your time and your brain !

Kind regards,
S.
Reply With Quote