View Single Post
  #1  
Old 17th March 2008, 12:26
Sammy Sammy is offline
Junior Member
 
Join Date: Mar 2008
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default The Perfect Setup - CentOS 4.3 (64-bit) Questions

Hello !

I have tried to set up a server here at home just for testing it out.
It will serve as my private test/web/file/mp3 server (I hope).
Maybe set it up later so that a friend can access it from the outside.

I followed The Perfect Setup - CentOS 4.3 (64-bit) (server-cd) tutorial (Great work!!!!)
Didn't find any Centos 4.3 64-bits server-cd ISO's
and no tutorial for v4.4 64-bit, but I guess this close-enough-mix will do.

But right now I feel like a stupid nobody that doesn't even know what to do with his toy.
Command line shell is just a little bit harder to get used to than I thought. But I will not give up.

I will take my experience from the start.. Maybe to detailed, but anyhow..
If You care to spend a few minutes I really will thank You!

Almost everything worked fine.
I have been able to figure out some trouble myselves,
but all my other friends are WinOnly so I guess I have to use forums on the rest..


(mySQL)

mySQL seemed to install fine.
However when I tried to check that networking was enabled it answered with:

tcp 0 0 *:mysql *:* LISTEN 3996/mysql

instead of
tcp 0 0 *:mysql *:* LISTEN 2995/mysql

that the tutorial said it would return..
Don't know what the numbers are? port? - but I guess it's ok?

-

When I tried to set up a password for the user root it typed exactly this:

mysqladmin -u root password yellowcar2
mysqladmin -h server1.myhomedomain.com -u root password yellowcar2

(Should I have substitued password with root-password? )

Anyhow - the response was:

Unknown command: yellowcar2
You have mail in /var/spool/mail/root


yellowcar2 - a command ?
Well.. reading command line mail at 3AM - later also

So I tried to run the:
mysqladmin -u root password yellowcar2
command again and every time I get this answer:

mysqladmin: connect to server at localhost failed
error: Access denied for user root @ localhost (using password: NO)


However mySQL starts and stops normal if I try to start or stop it.
I am also able to log into mySQL with: mysql -u root -p

---

(Apache)

I am able to see the CentOS defalt webpage when surfing the server IP.

One thing I don't get to work is to go to the user charlies webpage.

http://192.168.1.100/~charlie/
does not exist

http://192.168.1.100/charlie/
does not exist

Maybe CentOS does not create the user webspace and homefolder at same time ??



If anyone would like to comment on any part of my install I would be happy.
I am a real noob with linux, so please be gentle (but I am willing to learn)

Best Regards
Sammy
Reply With Quote
Sponsored Links