View Single Post
  #1  
Old 11th March 2008, 21:13
coolvik coolvik is offline
Junior Member
 
Join Date: Apr 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question Installing Yum in CentOS on a VPS

Hi,

I just found out that my VPS hasn't yum installed. So I found this guide to install it: http://wiki.centos.org/TipsAndTricks/BrokenVserver

After the step
Code:
rpm -Uvh *.rpm
I got quite many dependencies errors.
Code:
[root@bg yum]# rpm -Uvh *.rpm
warning: python-2.4.3-19.el5.i386.rpm: V3 DSA signature: NOKEY, key ID e8562897
error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by python-2.4.3-19.el5.i386
        libcrypto.so.6 is needed by python-2.4.3-19.el5.i386
        libdb-4.3.so is needed by python-2.4.3-19.el5.i386
        libreadline.so.5 is needed by python-2.4.3-19.el5.i386
        libssl.so.6 is needed by python-2.4.3-19.el5.i386
        rtld(GNU_HASH) is needed by python-2.4.3-19.el5.i386
        libc.so.6(GLIBC_2.4) is needed by python-elementtree-1.2.6-5.i386
        rtld(GNU_HASH) is needed by python-elementtree-1.2.6-5.i386
        libc.so.6(GLIBC_2.4) is needed by python-sqlite-1.1.7-1.2.1.i386
        rtld(GNU_HASH) is needed by python-sqlite-1.1.7-1.2.1.i386
        m2crypto >= 0.16-5 is needed by python-urlgrabber-3.1.0-2.noarch
        libc.so.6(GLIBC_2.4) is needed by sqlite-3.3.6-2.i386
        libreadline.so.5 is needed by sqlite-3.3.6-2.i386
        rtld(GNU_HASH) is needed by sqlite-3.3.6-2.i386
        rpm >= 0:4.4.2 is needed by yum-3.0.5-1.el5.centos.5.noarch
        rpm-python is needed by yum-3.0.5-1.el5.centos.5.noarch
        yum-metadata-parser is needed by yum-3.0.5-1.el5.centos.5.noarch
[root@bg yum]#

Seems to me that the hosting company have installed a minimal CentOS.

Is there any way to use the rpm command to get all those dependent packages as well?


Regards,
Daniel
Reply With Quote
Sponsored Links