View Single Post
  #5  
Old 6th January 2006, 12:00
Traxus Traxus is offline
Junior Member
 
Join Date: Jan 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Related to courier and postfix I know of the "mail" log, which contains informations about the attempted connects and disconnects, but otherwise I am a complete Linux noobie. Are the any other logs I could check, have you any recomendation? Maybe some specific log Courier notes down its actions?

Maybe I should mention that I encountered a bug in the Courier instalation on Suse 10, it does not per default assign the Courier SSL daemons to the correct ports, but to the non SSL ones. In the courier-pop3-ssl and couriter-imap-ssl daemon startup scripts were errors I fixed. I am wondering if anyone got ISPConfig working with courier on the released Suse 10, maybe there are additional glitches in there beside the wrong ports.
Thank You.

PS: I have restarted the system, now I have discovered following rather interesting entries in the mail log:
Code:
Jan  6 11:17:12 mars authdaemond: modules="authuserdb authpam authldap authcustom authpipe", daemons=5
Jan  6 11:17:12 mars authdaemond: Installing libauthuserdb
Jan  6 11:17:12 mars authdaemond: libauthuserdb.so: cannot open shared object file: No such file or directory
Jan  6 11:17:12 mars authdaemond: Installing libauthpam
Jan  6 11:17:12 mars authdaemond: Installation complete: authpam
Jan  6 11:17:12 mars authdaemond: Installing libauthldap
Jan  6 11:17:12 mars authdaemond: libauthldap.so: cannot open shared object file: No such file or directory
Jan  6 11:17:12 mars authdaemond: Installing libauthcustom
Jan  6 11:17:12 mars authdaemond: Installation complete: authcustom
Jan  6 11:17:12 mars authdaemond: Installing libauthpipe
Jan  6 11:17:12 mars authdaemond: Installation complete: authpipe
Jan  6 11:17:22 mars postfix/postfix-script: starting the Postfix mail system
Jan  6 11:17:22 mars postfix/master[5252]: daemon started -- version 2.2.5, configuration /etc/postfix
Another few facts:
"telnet localhost 143" replies:
Code:
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc.  See COPYING for distribution information.
"telnet localhost 993" replies
Code:
* OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2005 Double Precision, Inc.  See COPYING for distribution information.
Shouldnt a normal telnet to port 993 be straightly rejected?

"openssl s_client -connect localhost:993" replies
Code:
CONNECTED(00000003)
6868:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:494:
The above implies that there is a daemon running on port 993, but its not supporting the SSL protocol? I cannot currently attempt to connect through a client to it, will try that in the later afternoon.

Last edited by Traxus; 6th January 2006 at 13:10.
Reply With Quote