View Single Post
  #1  
Old 14th February 2008, 19:28
veremchook veremchook is offline
Junior Member
 
Join Date: Feb 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix email server config

I've recently set up a dedicated postfix server on fc8. When I send an email to one of my xxx domain accounts I get the following:

Final-Recipient: rfc822; adam@xxx.co.uk
Action: failed
Status: 4.0.0
Diagnostic-Code: X-INTERIA-PL; connect to xxx.co.uk[XXX.XXX.XXX.XXX]:
Connection refused


The domain name and ip address are correct, so I don't think it's a dns issue.

My main.cf file (uncommented lines only, most of them are dafault values):

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = xxx
(xxx it's the LAN machine name)
mydomain = xxx.co.uk
myorigin = xxx.co.uk
inet_interfaces = localhost
mydestination = $myhostname, localhost.$mydomain, localhost, $myhostname.$mydomain, /etc/postfix/mydestination
unknown_local_recipient_reject_code = 550
mynetworks_style = subnet
relay_domains = $mydestination
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.4.5/samples
readme_directory = /usr/share/doc/postfix-2.4.5/README_FILES


Some additional info:

[root@xxx ~]# cat /etc/passwd | grep adam
adam:x:500:500::/home/adam:/sbin/nologin

[root@xxx ~]# chkconfig --list | grep postfix
postfix 0:off 1:off 2:on 3:on 4:on 5:on 6:off

[root@xxx ~]# ps aux | grep postfix
root 1469 0.0 0.3 6940 1796 ? Ss Feb08 0:00 /usr/libexec/postfix/master
postfix 1476 0.0 0.3 7064 1836 ? S Feb08 0:00 qmgr -l -t fifo -u
postfix 19091 0.0 0.3 7004 1776 ? S 17:05 0:00 pickup -l -t fifo -u
root 19113 0.0 0.1 4048 680 pts/0 S+ 17:14 0:00 grep postfix


The port forwarding on our gateway also seems to be fine. I'm using SpeedTouch 5x6 "Game & Application Sharing" tool.
hits on port 110 (pop3) are set to be redirected to xxx:110
hits on port 25 (smtp) are set to be redirected to xxx:25

Please help and advise where to dig to solve my problem and start some basic email exchange on my server.
Cheers
Adam
Reply With Quote
Sponsored Links