View Single Post
  #6  
Old 4th February 2008, 17:26
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
If your ISPConfig 2.2.19 update stops, dont panic. Please check if you see the following error message in the compilation output:



This error may occur if you use a older linux distribution like Ubuntu 6.x, SuSE 10 or Fedora 4 (just a few where I heard about this problem). This problem is caused by the ClamAV script, the ClamAV developers have added a check that prevents the compilation of the latest ClamAV version with some gcc compiler versions which are buggy.

The recommended solution from the ClamAV dev's: Update GCC

The problem is, newer gcc packages are not available anymore for these linux distributions. Older gcc versions may work too, so downgrading gcc can be an option.

I collected here some workarounds:

Ubuntu 6.06 LTS: http://www.howtoforge.com/forums/sho...4&postcount=27
Tried this on an Ubuntu 6.06.2 install and it keeps blowing up with the same error message. Downside is that during the install my complete root/ispconfig/ dir is deleted, but luckily the database and web/user data still exists.

:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 6.06.2 LTS
Release: 6.06
Codename: dapper

It's an up-to-date install and I have followed the steps to install gcc-3.4 and (re)create the /root/ispconfig/ dir

Guess I'll install 2.2.17 which worked fine and will give 2.2.20 a shot; if that also fails I guess I'll have to stick with the last working version.

The error I keep seeing is ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory

Last edited by wr19026; 4th February 2008 at 17:28.
Reply With Quote