View Single Post
  #1  
Old 2nd February 2008, 14:37
pjdevries pjdevries is offline
HowtoForge Supporter
 
Join Date: Sep 2006
Posts: 130
Thanks: 7
Thanked 12 Times in 5 Posts
Default suPHP, Joomla! 1.5, file & diretory permissions

Joomla! 1.5 is officially released, so I decide to use it for my next website. Unfortunately I ran into a file & directory permission problem I also ran into using Joomla! 1.0.13. The problem has to do with suPHP and the default file & directory creation permissions of Joomla! and it first appeared when I tried to get WYSIWYG editors to work. For Joomla! 1.x the problem could be solved by changing the default creation permissions in the "Global Configration - Server" section of the Joomla! administrator back-end (thanks to Hans for the tip). Changing the default directory permissions to 0775 instead of the default 755 (and applying them to existing directories) solved the problem.

In Joomla! 1.5 that administrator section doesn't exist anymore and so I'm stuck once again. Is there an alternative Apache and/or ISPConfig way of solving this problem? I don't know if Joomla! explicitly sets permissions or uses the system default umask. If it does use the system umask however, I would like to know how to change that for my Apache + suPHP setup. I would also like to know if it's possible to have a different umask for file and directory creation.
Reply With Quote
Sponsored Links