View Single Post
  #15  
Old 25th January 2008, 20:38
peacengell peacengell is offline
Member
 
Join Date: Jan 2008
Posts: 37
Thanks: 10
Thanked 2 Times in 2 Posts
Default hi falko ur the best

hi falko thanks 4 any help yeah but the problem is the same as telnet localhost 25
adn here is the result
server:/# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
ehlo localhost


so i'm using vmware and bridged conection is there any config i need to change i use putty to administer my server it's work fine on the lan but not on lan
should i used any othe protocole lik nat or host-only or custom
please i need to learn these steps i wanna learn that why i ask a lot of question sorry for that but see u falko ur the bst in linux i seen ur webpage nice one ilike ti maybe if my go well i will try to hots one thanks in many ways and a milion thanks to howtoforge.com and all members as a hard work is been done here thanks a lot for all ur help


i re done the process from postfix here is all the command i used
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package dns
server:/# clear
server:/# apt-get install postfix libsas12 sasl12-bin libsas12-modules libdb3-util procmail
Reading package lists... Done
Building dependency tree... Done
postfix is already the newest version.
E: Couldn't find package libsas12
server:/# apt-get install libsas12
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package libsas12
--10:18:36-- http://libsas12/
=> `index.html'
Resolving libsas12... failed: Name or service not known.

FINISHED --10:18:38--
Downloaded: 0 bytes in 0 files
server:/# clear
server:/# dpkg-reconfigure postfix
Stopping Postfix Mail Transport Agent: postfix.
setting synchronous mail queue updates: false
setting myorigin
setting destinations: server.peacengell.org,localhost.peacengell.org,loc alhost.localdomain,localhost
setting relayhost:
setting mynetworks: 127.0.0.0/8
setting mailbox_command
setting mailbox_size_limit: 0
setting recipient_delimiter: +
setting inet_interfaces: all
setting inet_protocols: all

Postfix is now set up with the changes above. If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed. To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
server:/# clear
server:/#
server:/# postconf -e 'smtpd_sasl_local_domain ='
server:/# postconf -e 'smtpd_sasl_auth_enable = yes'
server:/# postconf -e 'smtpd_sasl_security_options = noanonymous'
server:/# postconf -e 'broken_sasl_auth_clients = yes'
server:/# postconf -e smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination'
>
>
server:/# postconf -e smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination'

>
server:/# postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination'

server:/# postconf -e 'inet_interfaces =all'
server:/# echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf
server:/# echo 'mech_list: plain login' >> /etc/p
pam.conf passwd perl/ ppp/ protocols python2.4/
pam.d/ passwd- postfix/ profile python/
server:/# echo 'mech_list: plain login' >> /etc/postfix/s
sasl/ ssl/
server:/# echo 'mech_list: plain login' >> /etc/postfix/sasl/smtpd.conf
server:/# mkdir /etc/postfix/ssl
mkdir: cannot create directory `/etc/postfix/ssl': File exists
server:/# cd /etc/postfix/s
sasl/ ssl/
server:/# cd /etc/postfix/ssl/
server:/etc/postfix/ssl# openssl genrsa -des3 -rand /etc/hosts -out smtpd.key1024
292 semi-random bytes loaded
Generating RSA private key, 512 bit long modulus
...++++++++++++
................++++++++++++
e is 65537 (0x10001)
Enter pass phrase for smtpd.key1024:
4499:error:28069065:lib(40):UI_set_result:result too small:ui_lib.c:849:You must type in 4 to 8191 characters
Enter pass phrase for smtpd.key1024:
Verifying - Enter pass phrase for smtpd.key1024:
server:/etc/postfix/ssl# chmod 600 smtpd.key
server:/etc/postfix/ssl# openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt
Signature ok
subject=/C=IE/ST=dublin/L=dublin/O=learning/OU=peace/CN=peacengell.org/emailAddress=peacengell@gmail.com
Getting Private key
server:/etc/postfix/ssl# openssl rsa -in smtpd.key -out smtp.key.unecrypted
writing RSA key
server:/etc/postfix/ssl# mv -f smtpd.key.unecrypted smtpd.key
mv: cannot stat `smtpd.key.unecrypted': No such file or directory
server:/etc/postfix/ssl# openssl req -new -x509 -extentions v3_ca -keyout cakey.pem -out acert.pem -days 3650
unknown option -extentions
req [options] <infile >outfile
where options are
-inform arg input format - DER or PEM
-outform arg output format - DER or PEM
-in arg input file
-out arg output file
-text text form of request
-pubkey output public key
-noout do not output REQ
-verify verify signature on REQ
-modulus RSA modulus
-nodes don't encrypt the output key
-engine e use engine e, possibly a hardware device
-subject out

Last edited by peacengell; 26th January 2008 at 00:58.
Reply With Quote