View Single Post
  #3  
Old 23rd January 2008, 03:54
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko
Any errors in your mail log?
1)
On Evolution

uncheck "server require authentication"


$ tail /var/log/mail.err
Code:
Jan  2 14:52:23 mail postfix[5415]: fatal: the postfix command is reserved for t
he superuser
Jan  4 15:20:26 mail postfix[6060]: error: to submit mail, use the Postfix sendm
ail command
Jan  4 15:20:26 mail postfix[6060]: fatal: the postfix command is reserved for t
he superuser
Jan  4 15:20:39 mail postfix[6061]: error: to submit mail, use the Postfix sendm
ail command
Jan  4 15:20:39 mail postfix[6061]: fatal: the postfix command is reserved for t
he superuser
Jan 10 20:50:04 mail postfix[5705]: error: to submit mail, use the Postfix sendm
ail command
Jan 10 20:50:04 mail postfix[5705]: fatal: the postfix command is reserved for t
he superuser
Jan 10 20:50:11 mail postfix[5706]: error: to submit mail, use the Postfix sendm
ail command
Jan 10 20:50:11 mail postfix[5706]: fatal: the postfix command is reserved for t
he superuser
Jan 21 11:39:05 mail postfix[5877]: fatal: myhostname and relayhost parameter se
ttings must not be identical: mail.satimis.com

$ tail /var/log/mail.log
Code:
Jan 23 08:59:45 mail authdaemond: Installing libauthpam
Jan 23 08:59:45 mail authdaemond: Installation complete: authpam
Jan 23 08:59:48 mail postfix/master[4928]: daemon started -- version 2.3.8, configuration /etc/postfix
Jan 23 09:37:15 mail postfix/smtpd[5441]: connect from host-22.124-157-220.dynamic.totalbb.net.tw[220.157.124.22]
Jan 23 09:37:15 mail postfix/smtpd[5441]: warning: support for restriction "reject_maps_rbl" will be removed from 
Postfix; use "reject_rbl_client domain-name" instead
Jan 23 09:37:16 mail postfix/smtpd[5441]: NOQUEUE: reject: RCPT from host-22.124-157-220.dynamic.totalbb.net.tw[22
0.157.124.22]: 554 5.7.1 Service unavailable; Client host [220.157.124.22] blocked using bl.spamcop.net; Blocked -
 see http://www.spamcop.net/bl.shtml?220.157.124.22; from=<bostjan182@schow.biz> to=<mail@satimis.com> proto=ESMTP
 helo=<[220.157.124.22]>
Jan 23 09:37:16 mail postfix/smtpd[5441]: disconnect from host-22.124-157-220.dynamic.totalbb.net.tw[220.157.124.2
2]
Jan 23 09:40:36 mail postfix/anvil[5444]: statistics: max connection rate 1/60s for (smtp:220.157.124.22) at Jan 2
3 09:37:15
Jan 23 09:40:36 mail postfix/anvil[5444]: statistics: max connection count 1 for (smtp:220.157.124.22) at Jan 23 0
9:37:15
Jan 23 09:40:36 mail postfix/anvil[5444]: statistics: max cache size 1 at Jan 23 09:37:15

2)
On Evolution

check "server require authentication"
PLAIN

$ tail /var/log/mail.log
Code:
Jan 23 10:28:43 mail postfix/smtpd[5515]: NOQUEUE: reject: RCPT from unknown[220.232.213.178]: 554 5.7.1 <satimisliu@gmail.com>: Relay access denied; from=<smsliu@satimis.com> to=<satimisliu@gmail.com> proto=ESMTP helo=<[192.168.0.11]>
Jan 23 10:28:43 mail postfix/smtpd[5515]: disconnect from unknown[220.232.213.178]
Jan 23 10:31:15 mail postfix/smtpd[5521]: connect from unknown[220.232.213.178]
Jan 23 10:31:15 mail postfix/smtpd[5521]: NOQUEUE: reject: RCPT from unknown[220.232.213.178]: 554 5.7.1 <satimisliu@gmail.com>: Relay access denied; from=<smsliu@satimis.com> to=<satimisliu@gmail.com> proto=ESMTP helo=<[192.168.0.11]>
Jan 23 10:31:15 mail postfix/smtpd[5521]: disconnect from unknown[220.232.213.178]
Jan 23 10:33:17 mail postfix/smtpd[5529]: connect from pool-71-179-10-74.bltmmd.fios.verizon.net[71.179.10.74]
Jan 23 10:33:19 mail postfix/smtpd[5529]: warning: support for restriction "reject_maps_rbl" will be removed from Postfix; use "reject_rbl_client domain-name" instead
Jan 23 10:33:19 mail postfix/smtpd[5529]: NOQUEUE: reject: RCPT from pool-71-179-10-74.bltmmd.fios.verizon.net[71.179.10.74]: 554 5.7.1 Service unavailable; Client host [71.179.10.74] blocked using bl.spamcop.net; Blocked - see http://www.spamcop.net/bl.shtml?71.179.10.74; from=<incurablytw93@freejesuspictures.com> to=<satimis@satimis.com> proto=ESMTP helo=<Wireless_Broadband_Router>
Jan 23 10:33:19 mail postfix/smtpd[5529]: lost connection after DATA from pool-71-179-10-74.bltmmd.fios.verizon.net[71.179.10.74]
Jan 23 10:33:19 mail postfix/smtpd[5529]: disconnect from pool-71-179-10-74.bltmmd.fios.verizon.net[71.179.10.74]

Quote:
What's in your main.cf?
$cat /etc/postfix/main.cf
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mail.satimis.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = satimis.com
mydestination = mail.satimis.com, satimis.com, localhost.satimis.com, localhost.localdomain, localhost
relayhost =
#mynetworks = 127.0.0.0/8, 192.168.1.0/24
mynetworks = 127.0.0.0/8, 192.168.0.0/24
mailbox_command = 
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
#smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
#smtpd_tls_auth_only = no
smtpd_tls_auth_only = yes
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
virtual_alias_maps = hash:/etc/postfix/virtual
# Specify your NAT/proxy EXTERNAL address here.
proxy_interfaces = 220.232.213.178
#proxy_interfaces = 1.2.3.4
#virtual_alias_domains = satimis.com satimis.changeip.net

# Enable SMTP authentication support
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $mydomain
unknown_local_recipient_reject_code = 450
maps_rbl_domains = 
    bl.spamcop.net,
    xbl.spamhaus.org

smtpd_recipient_restrictions =
     permit_mynetworks,
     permit_sasl_authenticated,
     reject_unauth_destination
     reject_invalid_hostname, 
     reject_non_fqdn_sender, 
     reject_non_fqdn_recipient, 
     reject_unknown_sender_domain, 
     reject_unknown_recipient_domain, 
     reject_unauth_pipelining, 
     reject_unauth_destination, 
     reject_maps_rbl, 

smtpd_client_restrictions = permit_mynetworks

Edit:


I suppose the problem coming from Evolution. I checked Kmail running on F7 (on another HD on the same Worksation). It can send and receive mails on the Mail Server without problem. However Evolution can send mails via ISP server.

satimis

Last edited by satimis; 23rd January 2008 at 13:40.
Reply With Quote