View Single Post
  #5  
Old 29th December 2005, 15:26
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by falko
No, it is not even mentioned in the tutorial...


Never had such problems. Make sure you follow the tutorial to the letter (except where you have to provide custom information).
One question: is it maybe a 64-bit Mandirva you're trying to install? Maybe that's why some of the packages are missing.
I don't know how mailman was installed. The only additional packages I installed was GNOME--during the Mandriva setup. I have been using http://www.falkotimme.com/howtos/per...10_2/index.php. I downloaded from the mirror you provided as well. I made sure the mode date of the tutorial was the same as the one on HTF. Everything I entered was copied and pasted from the tutorial (except for settings unique to my install--ip addresses, domain, etc.). I will mention that after I installed the o/s, I switched over to my WXP machine so I could putty the rest.

I understand now, why the four packages were missing:
Code:
tkinter-2.4-5mdk.i586
libgtkhtml-3.1_11-3.2.5-1mdk.i586
libgal-2.2_1-2.2.5-1mdk.i586
mailman-2.1.5-15mdk.i586
They are on the cd-rom #3, but they must have corrupted during the download, because I tried to install them after the fact; it asked for cd #3 and errored out because they corrupt. I was able to successfully download and install them from the ftp.lip6.fr mirror.

fileutils was replaced by a newer file, but I can't remember the name.

Went on to installing quota and it went okay (at least after I installed the above packages).

Everything seemed to be okay again until I got to the MySQL install. I ran:
Code:
apt-get install MySQL MySQL-client libmysql14-devel
This is what happened:
Code:
[root@server1 ~]# apt-get install MySQL MySQL-client libmysql14-devel
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libmysql14-devel: Depends: MySQL-common (= 4.1.11-1mdk) but 5.0.17-1mdk is to be installed
                    Depends: MySQL-client (= 4.1.11-1mdk) but 5.0.17-1mdk is to be installed
E: Broken packages
I tried installing these packages (MySQL-common and MySQL-client), but was unsuccessful. It said that I needed perl(dbi), which is a dependency of MySQL-client.

I thought I'd go on to perl, just to see what would happen there. Well, I went through all the configuration and when I tried to telnet localhost, it would not connect.

This is when I decided to put it to rest...

Any idea why I would have had the errors with MySQL? ...just for starters.
Reply With Quote