View Single Post
  #5  
Old 28th December 2007, 19:31
fsoyer fsoyer is offline
Junior Member
 
Join Date: Nov 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello all,
hello and thanks for work, Falko (and for so many answers on this forum, too !)

I have installed ISPConfig on an Etch with the http://www.howtoforge.com/perfect_setup_debian_etch, and it works fine.

Just this %!@#! smtp authentication....
After hours of research on the forum, I got it, so let me resume (hum hum, I'm afraid of not be able to do it short...) !

With this tuto, once the server has been set as MX for a domain, it receive mails for existing users (and aliases), and reject unknown recipients : good.
I had no real problem to use POP(S) and IMAP(S) for reading mails, just think to :
- check "Maildir" on ISPConfig admin/parameters/e-mail page, to avoid "chdir Maildir : not such file or directory" messages on server
- add right lines and ports in the ISPConfig firewall (admin->services->firewall) if enabled (respectively ports 25, 110, 995, 143 and/or 993).
I had no problem too for sending mail from the server itself.

The problem comes when I want to send mail through this server from a remote mail client (Evolution on my laptop).
First, no way to connect to the server with standard smtp. The first two hours of searchs and tests to find... that this is blocked by my ISP to avoid spams ! So the port 25 is used for MTA to MTA discuss (so it must be enabled on the server), but is used too for MUAs to MTA transfers, and that is blocked by ISPs (am I right ?).
Ok. After all, why not, spam is bad. Bouh.

So I try with SSL. The SMTPS port is 465, open it on firewall, blah blah blah.
Evolution is set to join the server with smtp on SSL, but first say "enable to connect to server". Finally, I noticed with a "nmap localhost" on server that Postfix was not listening on port 465, only 25.
The master.cf modification (smpts line) is the truth ! However, though the connect error is solved, nothing happened. Evolution is waiting and never ask for a password, and no messages on server except "postfix/smtpd[23942]: connect from xxxxx" then it fall in timeout.
Another hour to find that I had not commented out the option line of smtps (" -o smtpd_tls_wrappermode=yes") in master.cf !
Argh. But what a @!#?% !!!

So I can use ISPConfig installation and users as SMTP and Imaps/pops server. Pfooo !

Just note that the two last lines ("smtpd_sasl_auth_enable" and "smtpd_client_restrictions") are not necessary, since there are already in main.cf.

So, however some questions come to me :
1. Maybe the master.cf modification can be added to the Perfect setup, to avoid some other nightmares ?...
2. With Evolution I must check "use Maildir" on server in order to read mail. Is this necessary with others mail clients (Outlook, thunderbird...) ? And is Maildir format OK for this clients ? Not tested.
3. Which difference between TLS and SSL ? Evolution has this two options, but when I try "SMTP with TLS", it says "I/O error"... Some idea of why ? And how it works ?

Thanks again.
Reply With Quote