View Single Post
  #1  
Old 27th December 2007, 20:48
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache / httpd restart / startup failed without errors

I don't want you bother with my problems so I searched for 2 hours over the web for a solution for what I'm experiencing now. My apache is broken, but throws no errors. That makes it impossible to resolve it for me. The only thing error_log states:

[Thu Dec 27 19:15:08 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Dec 27 19:15:23 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Dec 27 19:16:45 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Dec 27 19:19:13 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

(SElinux is disabled as far as I know)

My apache was working well, till I needed to start ISP config again. That broke my server in some kind of way (really vague), httpd stopped. The server has been restarted, but that also restarted the ISP config server. The httpd server still didnt want to start (all other services do).

I uninstalled httpd and its dependencies and reinstalled them (using yum), using the new configs to test. No luck, still stopping w/o an error. There are no problems with modules as far as I can see. The error_log stays empty, debug level startup says nothing special, only messages log file says startup failed... (Dec 27 18:45:36 aerotronicvds httpd: httpd shutdown failed
Dec 27 18:52:10 aerotronicvds httpd: httpd startup failed)

The only value information for debugging this might be:
https://aerotronic.nl:81/stracehttpd.txt

I disabled the certificates by commenting those lines, it otherwise stopped at localhost.key or my website's certificate...

Thanks so much in advance for pointing me further!

I'm using CentOS 4.4, according to the perfect setup of this site.
Reply With Quote
Sponsored Links