HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Technical (http://www.howtoforge.com/forums/forumdisplay.php?f=8)
-   -   AHCI in Fedora Core 6 (http://www.howtoforge.com/forums/showthread.php?t=9996)

juan.villa 21st January 2007 23:15

AHCI in Fedora Core 6
 
Hi. I have an intel DG965WH motherboard with an Intel Core 2 Duo 2.16ghz and a Segate Barracuda 7200RPM 360gb HDD (w/ NCQ Support). I installed Fedora Core 6 with "IDE" enabled in the bios instead of "AHCI". After installing Fedora Core 6 and tweaking it I decided to activate "AHCI" in the hopes that it would work flawlessly, but I was wrong. Fedora Core 6 does not boot with "AHCI" activated. The error I get is that it can't find any LVMs and the kernel panics

-> uname -r
2.6.19-1.2895.fc6

-- My kernel boot options are as follow
rhgp quiet pci=nommconf all-generic-ide irqpoll

Any suggestions as to how to fix it?

THANKS! :)

Note: BIOS is at it's newest revision.

falko 22nd January 2007 15:47

I'd suggest a clean re-install.

juan.villa 22nd January 2007 16:14

Reinstall
 
Yep, I performed a clean reinstall and I was able to get AHCI support on the fly. I don't believe this should have been the way of doing this, considering the fact that linux is such a flexible operating system. I will look into it in the future, but if anyone has any has any opinions about this you're welcome to post it here. Thanks!

falko 22nd January 2007 21:25

Quote:

Originally Posted by juan.villa
I don't believe this should have been the way of doing this, considering the fact that linux is such a flexible operating system.

That's right, but sometimes a reinstall is much faster than trying to find a solution. ;) For example, I have no idea how to get AHCI working on an already installed system.


All times are GMT +2. The time now is 23:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.