HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Setting up Google Apps for my Domain (http://www.howtoforge.com/forums/showthread.php?t=9743)

meekish 12th January 2007 08:03

Setting up Google Apps for my Domain
 
I am trying to setup GMail for my domain. Google instructs me to enter the following MX records for my domain. I assume that I'm supposed to delete the standard "www.mydomain.com" MX record and replace it with the Google mailservers. However, I'm a little confused as to how I am actually supposed to enter these in the ISPConfig DNS Manager.

Code:

MX Server address                      Priority

ASPMX.L.GOOGLE.COM.                  1
ALT1.ASPMX.L.GOOGLE.COM.            5
ALT2.ASPMX.L.GOOGLE.COM.    5
ASPMX2.GOOGLEMAIL.COM.            10
ASPMX3.GOOGLEMAIL.COM.            10
ASPMX4.GOOGLEMAIL.COM.            10
ASPMX5.GOOGLEMAIL.COM.            10

In the "MX Record form" on ISPConfig, I have the following boxes:

* Hostname
* Priority [10, 20, 30, 40, 50, 60, 70, 80, 90]
* Mailserver

How would I translate the Google settings into that form? For example, would the first one be:

Hostname: ASPMX
Priority: 10
Mailserver: ASPMX.L.GOOGLE.COM.

And the second:

Hostname: ALT1
Priority: 50
Mailserver: ALT1.ASPMX.L.GOOGLE.COM.

and so on?

till 12th January 2007 10:42

The priority numbers do not really matter, what matters is the order.

it will be fine if you translate it like this:

1 = 10
5 = 20
10 = 30

You must enter the hostnames of the google mailservers without the dot at the end and the hostname field must be empty. Example:

Hostname:
Priority: 10
Mailserver: ASPMX.L.GOOGLE.COM

meekish 12th January 2007 18:03

Great. It seems to be working. Now I just need to figure out how to translate these instructions to the CP and I'm all set:

Quote:

1. Sign in to your domain hosting service.
2. Navigate to your DNS Management page. The location and name of this page will vary by host, but can generally be found through Domain Management or Advanced Settings.
3. Find the CNAME settings and enter the following as the CNAME value or alias:

mail

4. Set the CNAME destination to the following address:

ghs.google.com
5. Save changes on your domain hosting service. Then, return to this page and click on the "I've completed these steps" button below.
In ISPConfig, the CNAME form shows "Host" and "Target", so I'm thinking:

Host: mail
Target: ghs.google.com


Is that correct?

till 13th January 2007 13:55

Yes, that looks correct.

personxx 7th September 2007 15:33

Quote:

Originally Posted by till
The priority numbers do not really matter, what matters is the order.

it will be fine if you translate it like this:

1 = 10
5 = 20
10 = 30

You must enter the hostnames of the google mailservers without the dot at the end and the hostname field must be empty. Example:

Hostname:
Priority: 10
Mailserver: ASPMX.L.GOOGLE.COM

Why can't you for example add the following?
ALT1.ASPMX.L.GOOGLE.COM. 20
ALT2.ASPMX.L.GOOGLE.COM. 20

Everytime when I add a mx entry with the same priority I get the following message.

"This or a similar MX Record does already exist in this zone."

How can I make ISPConfig recognise the difference between ALT1 and ALT2 ?

till 8th September 2007 12:40

Just set the priority for the second entry to a higher value. Additionally, you do not nned these duplicate records, even if google lists them.

claudioimai 27th November 2008 05:43

Problem using ISPConfig, Google Apps and PHP's sendmail()
 
Hi,

I just fixed one problem in another thread, and stuck on another one.

The DNS problem for using Google Apps is all discussed in this thread, so I successfully set them, and my mail goes to Google Apps succesfully. Thanks for the help.

BUT, I had a further problem:

The servers I administer are primarily for use with webstores, which makes them send lots of emails from PHP to the store owner.
Example:

one store is set at http://store.domain.com/, and domain.com has the mx records pointing to Gmail in the DNS Manager

In ISP Manager, ISP Site / Options I changed the mailserver to "External mailserver" for all sites using the domain.

It should be enough to have this domain working, but any emails sent from the server are lost - I placed a code to log any emails sent from the scripts, and found this behaviour. The script updates the logs with the emails and subsequently, it sends the email, but it looks to be lost after being sent. It's not even on the trashbox (I thought gmail would do this trashing thing, just as hotmail, but it's not) :confused:

This is happening with 2 servers, could it be some other misconfiguration?

falko 27th November 2008 18:32

Did you select "External Mailserver" for the appropriate Co-Domains as well (can be set on the Co-Domains tab, after you've selected the Co-Domain)?

claudioimai 28th November 2008 03:31

Thanks, Falko

It worked!

kameleon25 14th April 2009 17:41

I too was searching for this answer. I just moved my zencart powered company site from "nightmare-host" to my local ISPconfig server. I use Google Apps for the domain and had all the MX records entered correctly. I could send/receive emails fine as long as it wasn't to my own domain. I would get errors about "no known user here" in the mail.log. The main problem is my store uses the PHP wrapper to send email and I got a similar disappearing email deal so I started digging and found this. I never thought about the "co-domain" part. Falko... you and Till are AWESOME! Now I just need to figure out how to move from ISPconfig2 to 3. I like the simplicity of 2. Just need a manual to read on 3 so I can know what does what. ;) hint hint


All times are GMT +2. The time now is 17:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.