HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   No login access by http or https (http://www.howtoforge.com/forums/showthread.php?t=963)

onoxsis 22nd October 2005 16:33

No login access by http or https
 
Hi first off i am a linux newbie:

The problem i am having is being able to access the ispconfig web page using the domain name, i can access it fine using the ip address.

I have double checked just to make sure port 81 wasn't being blocked and just to be sure changed the port to 8080.

When i acccess the webpage using the ip address most of the tabs don't work and timeout. such as in the management tab.

when running through the install: i did provide a host name: www
and then the domain name and i chose https.

i have installed/unistalled about 7 times now and still can't get this to work

need help!

Thankyou.

falko 22nd October 2005 16:40

You have to make sure that the domain name you provided during the installation resolves to your ISPConfig box. If it doesn't you can also use the IP address during the installation (leave the host name empty and enter the IP address as domain name). But before you do another install: you can change this in the file /home/admispconfig/ispconfig/lib/config.inc.php.

onoxsis 22nd October 2005 17:13

okay in this file: /home/admispconfig/ispconfig/lib/config.inc.php.
do i just go to the same line that i changed the port number to
and remove the domain name and replace with the machines ip address?

till 22nd October 2005 17:43

Yes, you can use an IP or Domain pointing to your server.

falko 22nd October 2005 19:20

It's the $go_info["server"]["server_url"] line.

onoxsis 23rd October 2005 07:57

Still didn't work
 
okay here is my settings: $go_info["server"]["server_url"] = "https://172.32.1.67:8080";

I can access the webpage fine but some links in management for eg:

click settings: https://172.32.1.67:8080/172.32.1.67
:8080/multidoc/edit/edit.php?doc_id=1&doctype_id=1010&

and get the following: Page cannot be displayed in ie and in mozilla firefox:

Not Found
The requested URL /172.32.1.67:8080/multidoc/edit/edit.php was not found on this server

Any other ideas?, i can't figure out what i am doing wrong!

till 23rd October 2005 13:07

Please send the complete file /home/admispconfig/ispconfig/lib/config.inc.php to t.brehm [at] ispconfig [dot] org and i will have a look on it. Before you send it please replace the mysql password inside with some xxx'es :)

onoxsis 24th October 2005 04:22

Email Sent
 
Hi okay i have sent you the file. Thankyou for helping me with this i really appreciate it. :)

till 24th October 2005 10:07

Quote:

Originally Posted by onoxsis
Hi okay i have sent you the file. Thankyou for helping me with this i really appreciate it. :)

I've checked your config file, in the URL is one slash missing:

$go_info["server"]["server_url"] = "https:/172.32.1.67:8080";

Correct URL:

$go_info["server"]["server_url"] = "https://172.32.1.67:8080";

onoxsis 24th October 2005 11:13

OMG Shoot me NOW!!!!!!!!!!!!!!!!!!!!!!!!
 
:eek: I can't believe i missed the most obvious syntax error, this goes to show that even a simple error like this can go unoticed.

Everything is up and working! now for step 2 trying to get it to work with the domain name.

Thankyou so much for the help! :)


All times are GMT +2. The time now is 21:30.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.