HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Domains and Subdomains (http://www.howtoforge.com/forums/showthread.php?t=9280)

braakiss 22nd December 2006 13:15

Domains and Subdomains
 
Hi,
what I would like to do is to have a domain like www.domain.com and several subdomains.
I want that those subdomains have their own emails:
www.domain.com with admin@domain.com user1@domain.com
sub1.domain.com with admin@sub1.domain.com user1@sub1.domain.com etc sub2.domain.com with admin@sub2.domain.com user1@sub2.domain.com etc

What I have done is:
1 I have created a reseller
2 I have created a client
3 I have created three sites for that client with this next configuration:

www.domain.com
Hostname:www
Domain:domain.com
Ip Address: 192.168.3.85
Create DNS: not checked
Create DNS-MX: not checked

sub1.domain.com
Hostname:www
Domain:sub1.domain.com
Ip Address: 192.168.3.85
Create DNS: not checked
Create DNS-MX: not checked

sub2.domain.com
Hostname:www
Domain:sub2.domain.com
Ip Address: 192.168.3.85
Create DNS: not checked
Create DNS-MX: not checked

The problem is that I can see the welcome web of "http://www.domain.com" but when I try to see the others ones "http://sub1.domain.com/" etc I see the web which says:
Quote:

This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

For questions or problems please contact the server administrator.
What Have I been doing wrong?

Thanks

till 22nd December 2006 13:19

Quote:

sub1.domain.com
Hostname:www
Domain:sub1.domain.com
Ip Address: 192.168.3.85
Create DNS: not checked
Create DNS-MX: not checked

sub2.domain.com
Hostname:www
Domain:sub2.domain.com
Ip Address: 192.168.3.85
Create DNS: not checked
Create DNS-MX: not checked
The correct setting is:

Hotsname: sub1
Domain: domain.com

and

Hotsname: sub2
Domain: domain.com

braakiss 22nd December 2006 13:33

So, can not I create emails account like xxx@sub1.domain.com?

If I put that configuration, host:sub1, when I go to create users and emails, the email ends with @example.com

thanks again

till 22nd December 2006 13:35

The email addresses are xxx@sub1.domain.com and not xxx@domain.com, just try it. Its only a display issue in the interface.

braakiss 22nd December 2006 13:56

I am a bit confused with this issue. I will try it.

Thanks again Till

braakiss 28th December 2006 15:06

Quote:

The email addresses are xxx@sub1.domain.com and not xxx@domain.com, just try it. Its only a display issue in the interface.
I tried it and it works. Thanks Till

ghesty 16th August 2007 12:25

Alias email?
 
Hi to everyone,

I'm a newbie about ISPconfig: I'm testing this software from monday :o
After some little configuration errors :rolleyes: all seems to work :D
The basic idea was to built a testing server, using dyndns and my old pc, so I need to create subdomains where I can copy web sites.

Now, this is the situation:
host: yyy
domain: zzz.dnsalias.com
user email: goofy@yyy.zzz.dnsalias.com

My doubt is:
goofy@yyy.zzz.dnsalias.com --> WORKS!
goofy@zzz.dnsalias.com ------> WORKS! ??? is it normal ???

Thanks to all of us for this great software, but, above all, this forum! :cool:

till 16th August 2007 12:33

If you added the domains as co-domains, then this is the correct behaviour.

If you want separate sites, you must create separate websitesa nd not co-domains.

ghesty 16th August 2007 15:27

Quote:

Originally Posted by till
If you want separate sites, you must create separate websitesa nd not co-domains.

Yes, I want subdomains as separate sites... here is my situation (#3)
http://www.howtoforge.org/forums/showthread.php?t=14620

something isn't working... probably a my configuration error :o

Thank you for the quick reply


All times are GMT +2. The time now is 04:07.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.