HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5) (http://www.howtoforge.com/forums/showthread.php?t=9237)

sapphire327 20th December 2006 19:21

Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)
 
I worked through this tutorial step by step, and successfully installed everything on a Fedora 5 VMware system. I then proceeded to go through the tutorial again on my actual server, and I ran into a problem:

This is what shows up in /var/log/maillog
Quote:

Dec 20 10:10:53 mail postfix/smtpd[11839]: fatal: no SASL authentication mechanisms
Dec 20 10:10:54 mail postfix/master[3075]: warning: process /usr/libexec/postfix/smtpd pid 11839 exit status 1
Dec 20 10:10:54 mail postfix/master[3075]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
These three lines appear repeatedly in the log file, and running a tail -f on it shows that they appear roughly every minute, and not in response to me trying to connect to port 25.

Trying to telnet to port 25 just disconnects me, or doesn't show the ESMTP greeting line.

The problem I am having is that I followed the directions exactly, and it worked the first time, and didn't work the second. I also re-installed my live server, and ran through the tutorial again, thinking I may have missed a step, but it still didn't work.

My config files look exactly like they do in the tutorial, and they also look the same as they do on my VMware server. SElinux is disabled.

If I disable SASL authentication in postfix, by entering postconf -e 'smtpd_sasl_auth_enable = no', then I can connect to the server and send a message successfully. However, I need SMTP authentication support, so I want to get this working.

I have looked through other forum posts, but everyone else's problems are different from mine. Can anybody offer an explanation?

Thanks,

Aaron Parecki

till 21st December 2006 11:17

Is SASL started?

sapphire327 21st December 2006 22:11

Thanks for replying. Yes, it is started, though.

falko 22nd December 2006 14:30

What's in /usr/lib/sasl2/smtpd.conf? What's the output of
Code:

uname -m
?

sapphire327 22nd December 2006 18:07

This is the output. It is the same on both the working and the not working computers.

Quote:

[root@mail ~]# cat /usr/lib/sasl2/smtpd.conf
pwcheck_method: authdaemond
log_level: 3
mech_list: plain login
authdaemond_path:/var/spool/authdaemon/socket

[root@mail ~]# uname -m
i686

falko 23rd December 2006 16:16

What's in /etc/postfix/main.cf (please strip out the comments)?

sapphire327 24th December 2006 02:27

Thanks, here it is.

Quote:

[aaron@mail ~]$ grep '^[^#]' /etc/postfix/main.cf
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
mydestination = mail.parecki.com, localhost, localhost.localdomain
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases


debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
myhostname = mail.parecki.com
mynetworks = 127.0.0.0/8
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
smtpd_sasl_local_domain = mail.parecki.com
mailbox_transport = virtual
[aaron@mail ~]$

falko 24th December 2006 14:16

Quote:

Originally Posted by sapphire327
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps

Is this in one line?

Quote:

smtpd_sasl_local_domain = mail.parecki.com
Please run
Code:

postconf -e 'smtpd_sasl_local_domain ='
/etc/init.d/postfix restart


sapphire327 24th December 2006 22:34

yes, it is all on one line.

I ran

postconf -e 'smtpd_sasl_local_domain ='
/etc/init.d/postfix restart

but still the same problem.

Quote:

[root@mail ~]# saslauthd -v
saslauthd 2.1.21
authentication mechanisms: getpwent kerberos5 pam rimap shadow ldap
Is it a problem that authdaemond does not show up in that list? I tried changing the pwcheck_method in /usr/lib/sasl2/smtpd.conf to shadow, but that didn't help.

Also please note that at the moment, mail.parecki.com does not actually point to this machine. I can give you access to my machine directly if you think you would be able to solve this faster that way, then post the solution to the forum. My machine is a VPS, so I can easily restore it back to the current state for any reason.

falko 25th December 2006 13:26

Did you install/compile all packages exactly as shown on the first page? http://www.howtoforge.com/fedora_vir..._quota_courier


All times are GMT +2. The time now is 12:04.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.