HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig SuSE 9.2 (http://www.howtoforge.com/forums/showthread.php?t=868)

abselect 15th October 2005 20:55

ISPConfig SuSE 9.2
 
Ok all went well at first ;-)
made a few changes to compile as recomended

./compile changes as recomended

--with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64

and did the bug fix for mysql libs

got right through to make php then this...

t -lz -lssl -lcrypto -lresolv -lm -ldl -lnsl -lcrypt -lcrypt -o libphp5.la
/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.4/../../../../x86_64-suse-linux/bin/ld: /root/ispconfig/openssl/lib/libssl.a(s2_srvr.o): relocation R_X86_64_32S against `ssl2_accept' can not be used when making a shared object; recompile with -fPIC
/root/ispconfig/openssl/lib/libssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [libphp5.la] Error 1
ERROR: Could not make PHP

So near but so far I can find no posts about this on

:rolleyes:

till 15th October 2005 21:07

You must install the openSSL devel packages from SuSe and compile PHP against them.

Maybe this thread helps you:

http://www.howtoforge.com/forums/sho...&highlight=php

abselect 15th October 2005 23:12

Quote:

Originally Posted by till
You must install the openSSL devel packages from SuSe and compile PHP against them.

Maybe this thread helps you:

http://www.howtoforge.com/forums/sho...&highlight=php

hmm I think I see my mistake I am going to try this ./configure
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openss --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"

abselect 15th October 2005 23:28

configure: error: The installed zlib version may contain a security bug. Please upgrade to 1.2.2 or later: http://www.zlib.net. You can omit this check with --disable-zlib-vcheck but DO NOT REPORT any stability issues then!
ERROR: Could not configure ClamAV
resolved the zlib with v 1.2.3 but....

/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.4/../../../../x86_64-suse-linux/bin/ld: /usr/local/lib/libz.a(gzio.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libz.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[2]: *** [libclamav.la] Error 1
make[2]: Leaving directory `/root/Desktop/install_ispconfig/compile_aps/clamav-0.87/libclamav'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Desktop/install_ispconfig/compile_aps/clamav-0.87'
make: *** [all] Error 2
ERROR: Could not make ClamAV

err umm what do I do about this?

falko 15th October 2005 23:37

Have a look here: http://www.howtoforge.com/forums/showthread.php?t=302
http://www.howtoforge.com/forums/showthread.php?t=147

abselect 15th October 2005 23:51

I edited post above above does this change things?

falko 16th October 2005 01:58

So you have a 64bit system... Maybe this thread helps you: http://www.howtoforge.com/forums/showthread.php?t=127

abselect 16th October 2005 12:04

Ok things are getting a bit confusing now so to recap, I have got past numerous errors resolved buy following other posts (much appreciated) so I am now very near the end but I can not get past clamav

make[1]: Entering directory `/root/Desktop/install_ispconfig/compile_aps/clamav-0.87'
Making all in libclamav

.
. removed to reduce post size next comes the error I am having
.
make[1]:/usr/lib64/gcc-lib/x86_64-suse-linux/3.3.4/../../../../x86_64-suse-linux/bin/ld: /usr/local/lib/libz.a(gzio.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libz.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[2]: *** [libclamav.la] Error 1
make[2]: Leaving directory `/root/Desktop/install_ispconfig/compile_aps/clamav-0.87/libclamav'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Desktop/install_ispconfig/compile_aps/clamav-0.87'
make: *** [all] Error 2
ERROR: Could not make ClamAV


I installed zlib-1.2.3 but still I get the error

OK so this seems like a solution

run

apt-get install zlib zlib-devel

and start ISPconfig setup again ./setup
then it will work.


Pulled most of my hair out

abselect 16th October 2005 22:27

Ok I got it all going now, thanks to all of you who have helped especially till and falko, your post hints were invaluable.
x86_64 issues are a major headake


All times are GMT +2. The time now is 16:26.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.