HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig system stoped (http://www.howtoforge.com/forums/showthread.php?t=860)

johnking 15th October 2005 08:04

ISPConfig system stoped
 
I've installed ISPConfig for the second time and each time this is the message I'm getting:

[root@server1 ~]# /etc/init.d/ispconfig_server restart
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
Starting ISPConfig system...
Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: cannot restore segment prot after reloc: Permission denied
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
ISPConfig system is now up and running!
[root@server1 ~]#
************************************************** ***************************************
Does anybody knows what I am doing wrong? I am running FC4
By the way excellent HOW-TOs. I really like your documentation GOOD JOB
Any help will be highly appreciated

Thanks

falko 15th October 2005 12:38

Can you post the output of
Code:

ls -l /root/ispconfig/httpd/libexec/libphp5.so
here?

till 15th October 2005 13:44

Have you installed SELinux or any other security extension or another security level as described in the howto?

johnking 22nd October 2005 05:21

Sorry for the delay. Below is request list.
************************************************** ************
[root@jkford ~]# ls -l /root/ispconfig/httpd/libexec/libphp5.so
-rwxr-xr-x 1 root root 7863128 Oct 14 22:52 /root/ispconfig/httpd/libexec/libphp5.so
[root@jkford ~]#
************************************************** ********************************************
I hope that helps

Thanks

rosa hsiao 26th October 2005 13:55

ISPConfig system stopped
 
I have exactly the same installation error as Johnking stated.

till 26th October 2005 14:00

Which Linux distribution do you use? 32 or 64 Bit?

have you enabled any security extensions?

rosa hsiao 26th October 2005 23:53

Quote:

Originally Posted by till
Which Linux distribution do you use? 32 or 63 Bit?

have you enabled any security extensions?

FC4 installed in my computer that is P4 3.0G hardware. I following the each step by HOW TO said.

rosa hsiao 27th October 2005 03:37

ISPConfig system stopped
 
I reinstalled ISPConfig again and found that if I deactivated the security function when installing SELinux security extension,the problem was solved finally!


All times are GMT +2. The time now is 01:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.