HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=19)
-   -   Cacti and ISPConfig: Monitoring Tool (http://www.howtoforge.com/forums/showthread.php?t=8501)

VMartins 25th November 2006 01:58

Cacti and ISPConfig: Monitoring Tool
 
Hello All,

This topic is for anyone that have some questions, suggestions or comments about the How To:
Cacti On An ISPConfig Server Within 10 Easy Steps - http://www.howtoforge.com/cacti_ispconfig.

Thanks,

Vinicius

wmunguiam 12th January 2007 20:47

Something is wrong!
 
Hello,
I use tutorial http://www.howtoforge.com/cacti_ispconfig

On ISPConfig I created a Site CACTI, in OPTIONS I ADDED a Database with database name: web1_db1 and user: web1_u1, then I download Cacti package and Installed and I had a problem in Step 4:

Step 4 - Setup the Cacti database:
Create the MySQL database (If you prefer, you can use the PHPMyAdmin):
sudo mysqladmin --user=root
Import the default cacti database:
sudo mysql web1_db1 < cacti.sql

and it is the response:

noc@manager:/var/www/web1/web$ sudo mysqladmin --user=web1_u1
mysqladmin Ver 8.41 Distrib 5.0.24a, for pc-linux-gnu on i486
Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license

Administration program for the mysqld daemon.
Usage: mysqladmin [OPTIONS] command command....
-c, --count=# Number of iterations to make. This works with -i
(--sleep) only.
.....
.....

--shutdown_timeout=#

Variables (--variable-name=value)
and boolean options {FALSE|TRUE} Value (after reading options)
--------------------------------- -----------------------------
count 0
force FALSE
compress FALSE
character-sets-dir (No default value)
default-character-set (No default value)
host (No default value)
port 3306
relative FALSE
socket /var/run/mysqld/mysqld.sock
sleep 0
ssl FALSE
ssl-ca (No default value)
ssl-capath (No default value)
ssl-cert (No default value)
ssl-cipher (No default value)
ssl-key (No default value)
ssl-verify-server-cert FALSE
user web1_u1
verbose FALSE
vertical FALSE
connect_timeout 43200
shutdown_timeout 3600

Default options are read from the following files in the given order:
/etc/mysql/my.cnf ~/.my.cnf /etc/mysql/my.cnf
The following groups are read: mysqladmin client
The following options may be given as the first argument:
--print-defaults Print the program argument list and exit
--no-defaults Don't read default options from any options file
....
....

variables Prints variables available
version Get version info from server
noc@manager:/var/www/web1/web$ sudo mysql web1_db1 < cacti.sql
-bash: cacti.sql: Permission denied
noc@manager:/var/www/web1/web$

What is the problem?? Why I can't import database cacti.sql to web1_db1??

falko 13th January 2007 16:00

Quote:

Originally Posted by wmunguiam
noc@manager:/var/www/web1/web$ sudo mysql web1_db1 < cacti.sql
-bash: cacti.sql: Permission denied
noc@manager:/var/www/web1/web$

What is the problem?? Why I can't import database cacti.sql to web1_db1??

Does your MySQL database have a username and password? have a look here: http://www.howtoforge.com/faq/6_4_en.html

wmunguiam 26th January 2007 23:47

you right my friend...

I forgot write -u and -p

thanks!!

ocweb 18th June 2007 02:46

Install on Centos5
 
Hope I am in the right spot to post questions on the HowTo....

I installed Cacti following the tutorial with the following differences;

Centos5 install as per howto.

1. Installed the repo/yum version of Cacti without downloading the version as described.
2. Copied the contents of Cacti under /var/www to the web folder.
3. Created a sub-domain (co-domain) for xzy.com to give cati.xyz.com.
4. Made permissions for the web folder install (cacti folder) the same as the user.

I followed all the other install directives with db/config/ etc.

The problem I have is the cacti.xzy.com url returns a 403 error. i have a webmail.xyz.com co-domain and it is fine. I have set up Cacti the same way. Permissions are the same.

To test, I have a simple html page and even with a direct request I get the same error.

I am a little bit lost as to repair this issue.

Thanks.

falko 19th June 2007 13:11

What's in Apache's error log?
What's the output of
Code:

ls -la /var/www
?

ocweb 19th June 2007 14:18

Thanks for the help..

The /etc/httpd/log/error.log contains this running from when I tried to configure Cacti;


[Tue Jun 19 21:53:31 2007] [error] an unknown filter was not added: PHP
[Tue Jun 19 21:53:31 2007] [error] an unknown filter was not added: PHP
[Tue Jun 19 21:53:41 2007] [error] an unknown filter was not added: PHP
[Tue Jun 19 21:53:41 2007] [error] an unknown filter was not added: PHP

This runs on the same 10 second interval fom Sunday....

Perhaps related to....

Quote:

*/5 * * * * php /var/www/cacti/poller.php > /dev/null 2>&1
Rather than Centos syntax?

The code ls -la /var/www gives user names and sites with permissions and the only cacti related entry is;

drwxr-xr-x 11 root root 4096 Jun 17 21:57 cacti

I would have posted the lot but I am a forum nube and couldn't work how to get the code box?!!!

falko 20th June 2007 15:17

Quote:

Originally Posted by ocweb
[Tue Jun 19 21:53:31 2007] [error] an unknown filter was not added: PHP
[Tue Jun 19 21:53:31 2007] [error] an unknown filter was not added: PHP
[Tue Jun 19 21:53:41 2007] [error] an unknown filter was not added: PHP
[Tue Jun 19 21:53:41 2007] [error] an unknown filter was not added: PHP

This runs on the same 10 second interval fom Sunday....

Take a look here: http://www.howtoforge.com/forums/sho...che2_php%22%5D

ocweb 21st June 2007 00:46

Thanks Falco, that repaired the recurring entry in the log.

I have seen the Cacti howto on Centos4 on this Site. Am I better to use the package manager to remove Cacti and undo the manual modifications and try that method.

OR.....

Not too proud to admit defeat when it is a production server. I have a mind to replicate the server with another box as a backup and I can use that as the test bed for the Cati install.

Should, from the poor description of what I have tried, be worried about any other items left by my attempt. I have already removed the inputted line from /etc/crontab.

Can I thankyou and all involved in this Site for all the help that you give and the great package that Ispconfig is. I had a failing server with another Panel installed and I found this one awesome. I am sleeping at night now..hahaha.:)

arevelo 8th August 2008 04:30

Cacti No Works
 
PLEASE HELP

I INSTALLED CACTI BUT WHEN I TRY TO DO GRAPH ON DEBUG MODE ALWAYS SHOWS THIS MESSAGE:

RRDTOOL SAYS:
error: opening '/opt/lampp/htdocs/cacti/switch_cpu_11.rrd'; NO SUCH FILE OR DIRECTORY


WHAT CAN I DO?

TKS


All times are GMT +2. The time now is 12:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.