HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Kernel Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=6)
-   -   I need help compiling kernel-source-2.4.27 on Ubuntu 6.06 (http://www.howtoforge.com/forums/showthread.php?t=8247)

Slyth100 16th November 2006 10:06

I need help compiling kernel-source-2.4.27 on Ubuntu 6.06
 
I have followed the instructions in the readme and typed make oldconfig which worked fine. I then typed in "make dep" and got this error:

gcc-3.3 -Wall -Wstrict-prtotoytpes -02 -fomit-frame-pointer -o scripts/mkdep scri pts/mkdep.c
make: gcc-3.3:Command not found
make: *** [scipts/mkdep] Error 127


Is this becuase i have gcc 4 installed and not gcc 3.3? Do I need to change the make file in some way?

I have been trying to figure this out but because i am a newbie to linux I don't know what this error means!!!

Any help would be greatly appreciated!!!:eek:

falko 17th November 2006 14:23

Quote:

Originally Posted by Slyth100
Is this becuase i have gcc 4 installed and not gcc 3.3?

Yes. What's the output of
Code:

apt-cache search gcc
?

Slyth100 18th November 2006 00:06

I have typed in apt-cache search gcc and this is what happens:
 
I have typed in apt-cache search gcc and this is what happens:

cpp - The GNU C preprocessor (cpp)
cpp-4.0 - The GNU C preprocessor
dpkg-dev - package building tools for Debian
gcc - The GNU C compiler
gcc-4.0 - The GNU C compiler
libgcj7-jar - Java runtime library for use with gcj (jar files)
libgcc1 - GCC support library
libgcj7 - Java runtime library for use with gcj
gcc-4.0-base - The GNU Compiler Collection (base package)
gcj-4.1-base - The GNU Compiler Collection (gcj base package)
gcc-3.3-base - The GNU Compiler Collection (base package)

So, what do I do now? :)

falko 18th November 2006 15:32

I don't know if it's the right package, but you can try
Code:

apt-get install gcc-3.3-base
But if it wants to remove other important packages, you should decide not to install it.


All times are GMT +2. The time now is 23:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.