HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Creating image with Systemimager (http://www.howtoforge.com/forums/showthread.php?t=8222)

cuongtim 15th November 2006 12:49

Creating image with Systemimager
 
Dear all,

I follow the guideline in http://www.howtoforge.com/howto_linux_systemimager to create an image using Systemimager.
When I run si_prepareclient --server myserver
and choose YES for both questions, then failed with the following output:
Using "sfdisk" to gather information about disk:
/dev/sda

start: (c,h,s) expected (1023,254,63) found (1023,0,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,7)
Use of uninitialized value in hash element at /usr/lib/systemimager/perl/SystemI
mager/Common.pm line 1042, <FH_IN> line 8.
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/scsi/scsi_mod.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/scsi/sd_mod.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/scsi/libata.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/scsi/ata_piix.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/fs/jbd/jbd.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/fs/ext3/ext3.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/net/sk98lin/sk98lin.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/snd-page-alloc.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/soundcore.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/snd.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/snd-timer.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/snd-pcm.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/oss/snd-mixer-oss.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/oss/snd-pcm-oss.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/seq/snd-seq-device.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/seq/snd-seq.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/seq/snd-seq-midi-event.
ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/seq/oss/snd-seq-oss.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/core/seq/snd-seq-dummy.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/pci/hda/snd-hda-codec.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/sound/pci/hda/snd-hda-intel.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/i2c/i2c-core.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/i2c/busses/i2c-i801.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/usb/host/ehci-hcd.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/usb/host/uhci-hcd.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/net/ipv6/ipv6.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/crypto/md5.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/acpi/ac.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/acpi/battery.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/acpi/button.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/acpi/video.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/md/dm-mod.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/net/sunrpc/sunrpc.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/net/bluetooth/bluetooth.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/net/bluetooth/l2cap.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/net/bluetooth/rfcomm/rfcomm.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/fs/autofs4/autofs4.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/parport/parport.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/char/lp.ko
Adding: /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/parport/parport_pc.ko
>>> Filesystem for new initrd: ext2
>>> Creating new initrd from: /tmp/.systemimager.4
>>> New initrd mount point: /tmp/.systemimager.5
>>> dd if=/dev/zero of=/etc/systemimager/boot/initrd bs=1024 count=23680
23680+0 records in
23680+0 records out

>>> mke2fs -b 1024 -m 0 -N 640 -F /etc/systemimager/boot/initrd
mke2fs 1.37 (21-Mar-2005)
/etc/systemimager/boot/initrd: Permission denied while setting up superblock[/COLOR]
>>> rm -fr /tmp/.systemimager.4 /tmp/.systemimager.5

FAILED: mke2fs -b 1024 -m 0 -N 640 -F /etc/systemimager/boot/initrd at /usr/lib/
systemimager/perl/SystemImager/UseYourOwnKernel.pm line 723.




I install systemimager-server 3.6.3-2 in my Debian 3.1 and systemimager-client 3.6.3-1 in Fedora Core 4.

Any help would be very appreciated.

Cuongtim

falko 16th November 2006 15:54

Quote:

Originally Posted by cuongtim
Dear all,

I follow the guideline in http://www.howtoforge.com/howto_linux_systemimager to create an image using Systemimager.
When I run si_prepareclient --server myserver
and choose YES for both questions, then failed with the following output:
Using "sfdisk" to gather information about disk:
/dev/sda

start: (c,h,s) expected (1023,254,63) found (1023,0,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,1)
start: (c,h,s) expected (1023,254,63) found (1023,1,7)
Use of uninitialized value in hash element at /usr/lib/systemimager/perl/SystemI
mager/Common.pm line 1042, <FH_IN> line 8.

There seems to be something wrong with your partitions. How did you partition your hard drive? What's in /etc/fstab?

cuongtim 17th November 2006 04:50

RE:Creating image with Systemimager
 
Dear Falko,

Here is the display of /etc/fstab:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
LABEL=SWAP-sda7 swap swap defaults 0 0
/dev/hdc /media/cdrom auto pamconsole,exec,noauto,managed 0 0

Cuongtim

falko 18th November 2006 14:55

Looks ok. I guess then that the problem is caused by using different SystemImager versions on the server and the client.


All times are GMT +2. The time now is 22:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.