HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Domain added multiple times to config (http://www.howtoforge.com/forums/showthread.php?t=819)

adamluz 11th October 2005 20:17

Domain added multiple times to config
 
Okay, it seems my apache keeps getting shutdown because because to many virtual hosts are identical or something. Can someone help me understand this...

I have changed the last three of the ip to prevent advertising of my domain.

Starting httpd: [Tue Oct 11 11:12:33 2005] [warn] VirtualHost 66.18.129.000:443 overlaps with VirtualHost 66.18.129.000:443, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Oct 11 11:12:33 2005] [warn] VirtualHost 66.18.129.000:443 overlaps with VirtualHost 66.18.129.000:443, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Oct 11 11:12:33 2005] [warn] VirtualHost 66.18.129.000:443 overlaps with VirtualHost 66.18.129.000:443, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Oct 11 11:12:33 2005] [warn] VirtualHost 66.18.129.000:443 overlaps with VirtualHost 66.18.129.000:443, the first has precedence, perhaps you need a NameVirtualHost directive
[Tue Oct 11 11:12:33 2005] [warn] NameVirtualHost 66.18.129.000:80 has no VirtualHosts
[Tue Oct 11 11:12:33 2005] [warn] NameVirtualHost 66.18.129.000:80 has no VirtualHosts
[Tue Oct 11 11:12:33 2005] [warn] NameVirtualHost 66.18.129.000:80 has no VirtualHosts
[Tue Oct 11 11:12:33 2005] [warn] NameVirtualHost 66.18.129.000:80 has no VirtualHosts
[FAILED]



In my webmin I see this: http://www.absz.com/many_domains.gif

falko 11th October 2005 21:02

Have a look at your httpd.conf (at the bottom). Is it possible the the file Vhosts_ispconfig.conf is included multiple times (because of several installation tries)?

Ovidiu 11th October 2005 21:07

btw. any explanation for this?

Quote:

hxxxx:/var/www/web7# /etc/init.d/apache2 reload
Reloading web server config...[Tue Oct 11 21:05:34 2005] [warn] NameVirtualHost 81.169.176.xxx:80 has no VirtualHosts
done.
hxxxx:/var/www/web7#

falko 11th October 2005 21:52

Quote:

Originally Posted by Tenaka
btw. any explanation for this?

This happens if you have more than one IP address, but your vhosts only use one IP address. Nothing to worry about.


All times are GMT +2. The time now is 05:21.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.