HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   UebiMiau webmail adding @localhostname to email address except first address. (http://www.howtoforge.com/forums/showthread.php?t=811)

Kamran Shah 10th October 2005 16:22

UebiMiau webmail adding @localhostname to email address except first address.
 
UebiMiau webmail adding @localhostname to email address except first address.

I composed and sent an email to following four recipients.
me@anydomain.com, me@yahoo.com, me@myoffice.com, me@meonserver.com

Email arrives at all four domains but To field looks like the one below.
me@anydomain.com; "me@yahoo.com"@myserverhostname.com; "me@myoffice.com"@myserverhostname.com; "me@meonserver.com"@myserverhostname.com

The first email address is always fine, no matter local or public domain but it adds@whateverlocalhostis to all other email addresses, any ideas?

falko 10th October 2005 17:15

Can you check what the value of append_dot_mydomain in /etc/postfix/main.cf is? It should be no (append_dot_mydomain = no). If you have to change /etc/postfix/main.cf, don't forget to restart Postfix!

Kamran Shah 10th October 2005 17:33

UebiMiau appending @localhostname to email address except except first address.
 
Quote:

Originally Posted by falko
Can you check what the value of append_dot_mydomain in /etc/postfix/main.cf is? It should be no (append_dot_mydomain = no). If you have to change /etc/postfix/main.cf, don't forget to restart Postfix!

Variable append_dot_mydomain was not defined in my original main.cf, output below:

[root@portal postfix]# grep append main.*
main.cf.default:append_dot_mydomain = yes

After adding append_dot_mydomain = no:

[root@portal postfix]# grep append_dot_mydomain main.*
main.cf:append_dot_mydomain = no
main.cf.default:append_dot_mydomain = yes

After I added append_dot_mydomain = no to main.cf, restarted postfix (service postfix restart), sent a test mail but no difference.

falko 10th October 2005 17:37

Then maybe it's a setting in Uebimiau... Maybe you can find something (a setting) in the web interface?

Kamran Shah 11th October 2005 13:08

Quote:

Originally Posted by falko
Then maybe it's a setting in Uebimiau... Maybe you can find something (a setting) in the web interface?

Any idea how to get the web interface for UebiMiau, I have looked at /webmail/ and /mailuser/ but can't find anything I could tweak with.

till 11th October 2005 17:01

The files uebimiau files are in the directory /home/admispconfig/ispconfig/web/webmail/


All times are GMT +2. The time now is 21:13.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.