HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig -> named BIND 9 issues *PLEASE HELP* (http://www.howtoforge.com/forums/showthread.php?t=8084)

mcinallym 10th November 2006 23:20

ISPConfig -> named BIND 9 issues *PLEASE HELP*
 
Trying to have ISPConfig installed on Cent OS 4.4 on Opteron 64 bit Asus 1U Rack server, 2 gigs RAM, SATA Raid 250 GB drives, software Raid.

Really need help with this.

When using ISPConfig to configure DNS, named fails to start.

/etc/init.d/named start
--> FAILED


named.conf
------------------------------------------------------------------------
options {
pid-file "/var/named/chroot/var/run/named/named.pid";
directory "/var/named";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "named.local";
};

zone "58.150.205.in-addr.arpa" {
type master;
file "pri.58.150.205.in-addr.arpa";
};


zone "mydomain.com" {
type master;
file "pri.mydomain.com";
};


//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////


------------------------------------------------------------------------


/var/log/messages

------------------------------------------------------------------------
Nov 10 17:04:32 myserver named[4390]: starting BIND 9.2.4 -u named -t /var/named/chroot
Nov 10 17:04:32 myserver named[4390]: using 2 CPUs
Nov 10 17:04:32 myserver named[4390]: loading configuration from '/etc/named.conf'
Nov 10 17:04:32 myserver named[4390]: listening on IPv4 interface lo, 127.0.0.1#53
Nov 10 17:04:32 myserver named[4390]: listening on IPv4 interface eth0, 205.150.58.159#53
Nov 10 17:04:32 myserver named[4390]: listening on IPv4 interface eth1, 192.168.1.112#53
Nov 10 17:04:32 myserver named[4390]: command channel listening on 127.0.0.1#953
Nov 10 17:04:32 myserver named[4390]: command channel listening on ::1#953
Nov 10 17:04:32 myserver named[4390]: couldn't open pid file '/var/named/chroot/var/run/named/named.pid': No such file or directory
Nov 10 17:04:32 myserver named[4390]: exiting (due to early fatal error)
Nov 10 17:04:32 myserver named: named startup failed

------------------------------------------------------------------------

till 11th November 2006 13:54

Looks like your BIND daemon is not chrooted correctly. Please post the output of:

ls -la /var/named/chroot/var/run/named/


All times are GMT +2. The time now is 13:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.