HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Segmentation fualt error during compile (http://www.howtoforge.com/forums/showthread.php?t=807)

kird03 10th October 2005 14:22

Segmentation fualt error during compile
 
I have tried the forum search but did find only one hit, saying to remove all old data... (which I did several times already..

Sofar i succeeded:
- tar xvfz ISPConfig*
- cd install_ispconfig
- /.setup

then the compile starts (I assume..) but it breaks off with following errors:
Code:

make[2]: Leaving directory `/home/bart/tmp/install_ispconfig/compile_aps/openssl-0.9.8/crypto/rc2'
making all in crypto/rc4...
make[2]: Entering directory `/home/bart/tmp/install_ispconfig/compile_aps/openssl-0.9.8/crypto/rc4'
gcc -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=k6 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM  -c -o rc4_skey.o rc4_skey.c
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
(cd asm; /usr/bin/perl5 rc4-586.pl elf -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=k6 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM > ../rx86-elf.s)
/bin/sh: line 1: 14011 Segmentation fault      /usr/bin/perl5 rc4-586.pl elf -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=k6 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM >../rx86-elf.s
make[2]: *** [rx86-elf.s] Fout 139
make[2]: Leaving directory `/home/bart/tmp/install_ispconfig/compile_aps/openssl-0.9.8/crypto/rc4'
make[1]: *** [subdirs] Fout 1
make[1]: Leaving directory `/home/bart/tmp/install_ispconfig/compile_aps/openssl-0.9.8/crypto'
make: *** [build_crypto] Fout 1
ERROR: Could not make OpenSSL

I''m kind of stuck here, re-installed and updated SLL to latested versions etc.
I''m using Mandrive 2005LE (mandrake 10.2) with full development section installed..

anyone a clue?!

falko 10th October 2005 16:59

Quote:

/bin/sh: line 1: 14011 Segmentation fault /usr/bin/perl5 rc4-586.pl elf -I.. -I../.. -I../../include -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -mcpu=k6 -DL_ENDIAN -DTERMIO -O3 -fomit-frame-pointer -Wall -DOPENSSL_BN_ASM_PART_WORDS -DOPENSSL_IA32_SSE2 -DSHA1_ASM -DMD5_ASM -DRMD160_ASM -DAES_ASM >../rx86-elf.s
Either a hard disk failure (then get a new one...), or maybe an incompatible binary... I'm not quite sure what you can do about that...

till 10th October 2005 17:11

If you dont get the segmentation fault always in the same step of the installation, it might be an issue with your RAM memory as well.

kird03 10th October 2005 17:50

Quote:

Originally Posted by till
If you dont get the segmentation fault always in the same step of the installation, it might be an issue with your RAM memory as well.


mm, is there a way to check the ram condition...
the error occurs everytime at a different place.. but always when compiling openSSL

error messages are different, but mostly segmentation fault...

if someone knows a RAM check that works with mandriva... I would like to know! :)

thanxx sofar!

till 10th October 2005 18:00

Maybe Mandriva has a memtest option when you boot from the first bootable install CD / DVD. As far as i know the Boot CD's of the Debian and Redhat have such an option.

themachine 12th October 2005 01:15

MemTest86
 
I've had good luck with MemTest86...

http://www.memtest86.com

Throw it on a floppy or what have you and go to town.. should give you some idea. I also wouldn't leave out the cpu... compiling anything with choke on a faulty proc.

I would recommend attempting to compile something else as well... if it fails there then hardware is bout the only thing it could be.... download a linux kernel and compile it for the hell of it... see what happens.

kird03 13th October 2005 10:47

Quote:

Originally Posted by themachine
I've had good luck with MemTest86...

http://www.memtest86.com

something is wrong with the hardware.. I'll do the test somewhere in the near future.. but also another compile actions crashes!

strange thing however.. this install has served as an ADSL gateway for some months without crashes... only now.. I get troubles!

themachine 15th October 2005 16:50

Honesly, that isn't all too surprising... I don't imagine that there is much load on the CPU/RAM for gateway services. You could use a box with faulty proc or RAM and have it work flawless... its when you really stress the hardware that it will die.

Good luck!

Con Hennekens 3rd January 2006 21:04

Hi,

I've been trying to install ISPConfig for over a few days now, and run into the same problem as desribed above. I tried a lot concerning the hardware issues mentioned. Changed harddrive, tried setups wit all different combinations of 2x 256 MB dimms, tried Ubunto as well as Suse10 and installed that both to the letter of the how-to.

The problem occurs each time in exactly the same time, always compiling OpenSSL. I tried the current version as well as the stable one. I only do not have a chance to try a completely different PC.

I think it's the best bet to give up now...

Con

I think it is save

falko 4th January 2006 00:50

If you're running a 64-bit Linux, have a look here:
http://www.howtoforge.com/forums/showthread.php?t=127
http://www.howtoforge.com/forums/showthread.php?t=286
http://www.howtoforge.com/forums/showthread.php?t=1626


All times are GMT +2. The time now is 14:01.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.