HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   DNS zones for mail exchange, subdomain, smtp and pop3 (http://www.howtoforge.com/forums/showthread.php?t=7846)

nabuk 1st November 2006 12:43

DNS zones for mail exchange, subdomain, smtp and pop3
 
Hi all,
I've just installed isp config on a fedora core 6 mac mini server. all works without problem, but i've some issue with dns and mail services.
Under dns setting i've specificated the name of my name server and enabled default mx creation.
When i add a domain, like: host: www domain: test.com, i enable both create dns and dns-mx, but in the zone file, i can read only:

www MX 10 ns.test.com

but by selecting default mx creation i should have:

MX 10 ns.test.com
www MC 10 ns.2bite.net

mail A server_ip

Is this a bug or a configuration problem of my server ? After istalling isp config I've changed the ip, but i've changed all the configuration file found.

Also,
i need to have some domain with name@domain.com email and dome other subdomain with mail@subdom.domain.com email, how can i do ?



Thanks

falko 2nd November 2006 14:39

Quote:

Originally Posted by nabuk
but by selecting default mx creation i should have:

MX 10 ns.test.com
www MC 10 ns.2bite.net

mail A server_ip

Please go to the Co-Domains tab and select test.com (without www), and then enable Default MX for test.com, too. Please remember: www.test.com != test.com. Up to now, you created an MX record for www.test.com, not for trst.com, and that's what you have in your zone file, so everything is ok.

Quote:

Originally Posted by nabuk
Also,
i need to have some domain with name@domain.com email and dome other subdomain with mail@subdom.domain.com email, how can i do ?

If subdom.domain.com should point to the domain.com web site, then you can add subdom.domain.com as a Co-Domain to the domain.com web site, and you will automatically have email addresses such as mail@domain.com and mail@subdom.domain.com.

If subdom.domain.com and domain.com are different web sites, simply create a new web site for subdom.domain.com in ISPConfig and then create email accounts for it.

nabuk 2nd November 2006 23:23

Quote:

Originally Posted by falko
Please go to the Co-Domains tab and select test.com (without www), and then enable Default MX for test.com, too. Please remember: www.test.com != test.com. Up to now, you created an MX record for www.test.com, not for trst.com, and that's what you have in your zone file, so everything is ok.

Just done, it will create

MX 10 mail.test.com

but not

mail A ip_address


Quote:

If subdom.domain.com should point to the domain.com web site, then you can add subdom.domain.com as a Co-Domain to the domain.com web site, and you will automatically have email addresses such as mail@domain.com and mail@subdom.domain.com.

If subdom.domain.com and domain.com are different web sites, simply create a new web site for subdom.domain.com in ISPConfig and then create email accounts for it.

Ok thanks

falko 3rd November 2006 16:05

Quote:

Originally Posted by nabuk
Just done, it will create

MX 10 mail.test.com

but not

mail A ip_address

Please post your zone file here.

nabuk 6th November 2006 00:11

Code:

$TTL        86400
@      IN      SOA    ns3.xxx.com. admin.test.com. (
                        2006110503      ; serial, todays date + todays serial #
                        28800              ; refresh, seconds
                        7200              ; retry, seconds
                        604800              ; expire, seconds
                        86400 )            ; minimum, seconds
;
                NS      ns3.xxx.com.              ; Inet Address of name server 1
                NS      ns4.xxx.com.              ; Inet Address of name server 2
;

www  MX      10 ns3.xxx.com.
  MX      10 ns3.xxx.com.

test.com.      A        192.168.1.1
www      A      192.168.1.1

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;


falko 7th November 2006 15:56

Did you enable Default MX under Management -> Server -> Settings -> DNS?


All times are GMT +2. The time now is 19:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.