HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Joomla images doesn't show off ! (http://www.howtoforge.com/forums/showthread.php?t=7732)

gabrix 27th October 2006 14:42

Joomla images doesn't show off !
 
Immages on my site doesn't show off ,check url: http://tor.gabrix.ath.cx/ to be precise images inside $DocumentRoot/images/* .So,no banners,no smilies,no joomla logo nothing from images dir down to the others directories.I tried with all file permissions possible also a straight 777 -R and all files and dirs are owned by apache user.The $DocumentRoot is also apache user homedir.
I run a debian stable kernel 2.6 with apache 1.3.There is a thread started about this on joomla.it http://forum.joomla.it/index.php?topic=10455.0
Unfortunaly it's in italian , but it is nearly a mounth i'm struggling on this and also people from joomla.it gave up on my post.
I just bought my machine it is a cpu intel 2.5ghz , it's a fresh debian installation and i can't figure out what can stop images from showing off !I also tried a test virtual host with a index.html pointig to load first an image from the joomla dir in question and it didn't work but it did from a dedicated document dir for the test virtualhost .
This site was on https in the first place than i got advised to change protocol so i went to http :confused: , i also changed cms from joomla1.5 beta(somebody sayd it handles https better :confused: ) to the latest mambo.
So the images dir in the joomla documentroot doesn't show but a normal index.html does from a dedicated test document root.
Thanks !

gabrix 27th October 2006 15:42

It's not for all images otherways pages would be blank ... images from templates directory does show off. Default joomla images , banners and icons don't.Also there is mambot mos_image that has as number order -10000 .Maybe it 's of some help !

gabrix 27th October 2006 18:41

Sorry for my english ... my italian is even worst ... is anything i can explain ????

falko 28th October 2006 17:21

Can you post the vhost configuration for the Joomla web site here?
Are there any .htaccess files in the Joomla web site? Any error messages in Apache's error log?

BTW, http://tor.gabrix.ath.cx/ doesn't work for me. Is your server down?

gabrix 2nd November 2006 00:40

I was off town so i shutted off my site too,now is up again this is my virtualhost:
Quote:

NameVirtualHost 192.168.1.6:80

<VirtualHost 192.168.1.6:80>
ServerName tor.gabrix.ath.cx
ServerAlias www.tor.gabrix.ath.cx
ServerAdmin gabrix@gabrix.ath.cx
DocumentRoot /var/www/torgab
ErrorLog /var/log/apache/tor_error.log
TransferLog /var/log/apache/tor_access.log
#RewriteEngine On
#Options +FollowSymlinks
#RewriteCond %{SERVER_PORT} !^443$
#RewriteRule /.* https://tor.gabrix.ath.cx/ [R]
#RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
#RewriteRule .* - [F]
</VirtualHost>
Apache logs don't show anything about the images this is the url of a 'not showing up' image:
http://tor.gabrix.ath.cx/images/stories/articles.jpg

falko 2nd November 2006 15:31

What's the output of
Code:

ls -l /var/www/torgab/images/stories/articles.jpg
?

gabrix 2nd November 2006 15:49

Quote:

root@mail:~# ls -l /var/www/torgab/images/stories/articles.jpg
-rw-r--r-- 1 gab gab 4569 Oct 12 2005 /var/www/torgab/images/stories/articles.jpg
default 644
this for the inside/ :
Quote:

root@mail:~# ls -l /var/www/torgab/images/
total 124
drwxr-xr-x 2 gab gab 4096 Jan 13 2006 M_images
-rw-r--r-- 1 gab gab 1352 Oct 12 2005 apply_f2.png
-rw-r--r-- 1 gab gab 1648 Sep 17 2005 archive_f2.png
-rw-r--r-- 1 gab gab 1620 Sep 17 2005 back_f2.png
drwxr-xr-x 2 gab gab 4096 Jan 13 2006 banners
-rw-r--r-- 1 gab gab 151 Oct 12 2005 blank.png
-rw-r--r-- 1 gab gab 564 Oct 12 2005 cancel.png
-rw-r--r-- 1 gab gab 1457 Oct 12 2005 cancel_f2.png
-rw-r--r-- 1 gab gab 1776 Sep 17 2005 css_f2.png
-rw-r--r-- 1 gab gab 1719 Sep 17 2005 edit_f2.png
-rw-r--r-- 1 gab gab 1150 Jan 15 2006 favicon.ico
-rw-r--r-- 1 gab gab 1744 Sep 17 2005 html_f2.png
drwxr-xr-x 7 gab gab 4096 Oct 28 04:48 immagini_sito
-rw-r--r-- 1 gab gab 44 Oct 12 2005 index.html
-rw-r--r-- 1 gab gab 7200 Oct 12 2005 joomla_logo_black.jpg
-rw-r--r-- 1 gab gab 190 Sep 17 2005 menu_divider.png
-rw-r--r-- 1 gab gab 1655 Sep 17 2005 new_f2.png
-rw-r--r-- 1 gab gab 2404 Oct 12 2005 powered_by.png
-rw-r--r-- 1 gab gab 1699 Sep 17 2005 preview_f2.png
-rw-r--r-- 1 gab gab 1800 Sep 17 2005 publish_f2.png
-rw-r--r-- 1 gab gab 437 Dec 23 2005 publish_x.png
-rw-r--r-- 1 gab gab 698 Oct 12 2005 save.png
-rw-r--r-- 1 gab gab 1822 Oct 12 2005 save_f2.png
drwxr-xr-x 2 gab gab 4096 Jan 13 2006 smilies
drwxr-xr-x 4 gab gab 4096 Jan 13 2006 stories
drwxr-xr-x 4 gab gab 4096 Oct 27 21:45 stories999
-rw-r--r-- 1 gab gab 502 Dec 23 2005 tick.png
-rw-r--r-- 1 gab gab 1525 Sep 17 2005 unarchive_f2.png
-rw-r--r-- 1 gab gab 1679 Sep 17 2005 unpublish_f2.png
-rw-r--r-- 1 gab gab 1658 Sep 17 2005 upload_f2.png

gabrix 2nd November 2006 18:01

Grazie a Stephan we got over this problem .We were going to give up once the owner of the $DocumentRoot was apache owner and permissions were regular defaults 755 644.We had a look to apache logs and found the b.... :
Quote:

[Thu Nov 2 17:22:07 2006] [error] [client 130.82.151.252] Directory index forbidden by rule: /usr/share/images/
We had just to change the alias /images/ /usr/share/images to alias /img/ /usr/share/images/ so apache could find images and bosh ... images! http://tor.gabrix.ath.cx Thanks a lot you are great !
p.s.
i explained badly , sorry !


All times are GMT +2. The time now is 03:34.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.