HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   CentOS 4.4 mysql5 php5 upgrade (http://www.howtoforge.com/forums/showthread.php?t=7378)

hoihtah 10th October 2006 22:20

CentOS 4.4 mysql5 php5 upgrade
 
I was wondering if anyone was able to upgrade their CentOS 4.4 server to mysql 5 & php 5.

i had centos 4.4 and ispconfig installed with older/default version. however, when i tried to yum update with centos plus repositories enabled, it errored out when i try to restart httpd, mysqld.

i'd like to use centos if possible, but i do need php5 and mysql5. should i try a different linux distro?

any help would be appreciated.

till 11th October 2006 10:18

Which errors do you get when you start mysql or apache? Do you get any errors in the logfiles, especially the apache error log?

hoihtah 11th October 2006 19:37

hey till,

sorry for being such a newb.
your help would be greatly appreciated.

i would like to install centos 4.4 + ispconfig with php5 & mysql5.
i can go through the how-to and successfully install everything, except for php5 & mysql5.

after completing ispconfig install, what steps should I take to upgrade to php5 & mysql5?

i've literally installed over a dozen times, trying to get this to work.
last night, i even installed debian 3.1, thinking that it'd be easier to upgrade to php5 & mysql5... but i'm hitting another wall with that one.

thanks in advance for your help.

till 12th October 2006 10:17

Neither debian nor Centos ship with php5 out of the box. For debian you can add a repository like backports.org to your sources.list to get php5.

The easierw ay for you might be to choose a linux distribution which ships with php5 out of the box like Ubuntu (server), Fedora Core 5 or the latest SuSE linux. There are perfect setup guides available for these linux distributions.

falko 13th October 2006 15:53

Quote:

Originally Posted by hoihtah
i would like to install centos 4.4 + ispconfig with php5 & mysql5.
i can go through the how-to and successfully install everything, except for php5 & mysql5.

Have a look here: http://www.howtoforge.com/perfect_se...4#comment-3051

diomet 6th November 2006 18:17

Quote:

Originally Posted by falko

Can you please tell me the packages tu update from php4 to php5?

yum update ..................... ?

Thank you in advance!

falko 7th November 2006 16:46

You can search for PHP5 packages like this:
Code:

yum search php5
You can install the packages like this:
Code:

yum install package1 package2 ...


All times are GMT +2. The time now is 11:46.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.