HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Fedora Core 3 Problem (http://www.howtoforge.com/forums/showthread.php?t=734)

bccisp01 2nd October 2005 16:08

Fedora Core 3 Problem
 
Okay everyone I am trying to install this and configure it. I am at the point where I am grabbing the file apt-* and here is my results after trying this,

rpm -ivh http://ftp.freshrpms.net/pub/fedora/...6.fc4.i386.rpm
Retrieving http://ftp.freshrpms.net/pub/fedora/...6.fc4.i386.rpm
warning: /var/tmp/rpm-xfer.7cKQxm: V3 DSA signature: NOKEY, key ID 1ac70ce6
error: Failed dependencies:
libcrypto.so.5 is needed by apt-0.5.15cnc7-6.fc4.i386
libkrb5support.so.0 is needed by apt-0.5.15cnc7-6.fc4.i386
libreadline.so.5 is needed by apt-0.5.15cnc7-6.fc4.i386
librpm-4.4.so is needed by apt-0.5.15cnc7-6.fc4.i386
librpmdb-4.4.so is needed by apt-0.5.15cnc7-6.fc4.i386
librpmio-4.4.so is needed by apt-0.5.15cnc7-6.fc4.i386
libsqlite3.so.0 is needed by apt-0.5.15cnc7-6.fc4.i386
libssl.so.5 is needed by apt-0.5.15cnc7-6.fc4.i386
libstdc++.so.6(GLIBCXX_3.4.4) is needed by apt-0.5.15cnc7-6.fc4.i386

I know this has something to do with GPG keys how do i fix it?

Thanks,
Michael

falko 2nd October 2005 20:50

Quote:

Originally Posted by bccisp01
Okay everyone I am trying to install this and configure it. I am at the point where I am grabbing the file apt-* and here is my results after trying this,

rpm -ivh http://ftp.freshrpms.net/pub/fedora/...6.fc4.i386.rpm
Retrieving http://ftp.freshrpms.net/pub/fedora/...6.fc4.i386.rpm
warning: /var/tmp/rpm-xfer.7cKQxm: V3 DSA signature: NOKEY, key ID 1ac70ce6
error: Failed dependencies:
libcrypto.so.5 is needed by apt-0.5.15cnc7-6.fc4.i386
libkrb5support.so.0 is needed by apt-0.5.15cnc7-6.fc4.i386
libreadline.so.5 is needed by apt-0.5.15cnc7-6.fc4.i386
librpm-4.4.so is needed by apt-0.5.15cnc7-6.fc4.i386
librpmdb-4.4.so is needed by apt-0.5.15cnc7-6.fc4.i386
librpmio-4.4.so is needed by apt-0.5.15cnc7-6.fc4.i386
libsqlite3.so.0 is needed by apt-0.5.15cnc7-6.fc4.i386
libssl.so.5 is needed by apt-0.5.15cnc7-6.fc4.i386
libstdc++.so.6(GLIBCXX_3.4.4) is needed by apt-0.5.15cnc7-6.fc4.i386

I know this has something to do with GPG keys how do i fix it?

Thanks,
Michael

I think the gpg key is not the problem, it's only a warning there. You can fix the gpg problem by running
Code:

rpm --import /usr/share/rhn/RPM-GPG-KEY*
But there are some failed dependencies.
Did you follow http://www.howtoforge.com/perfect_setup_fedora_core_3 step by step?
If you don't succeed with apt, you can use yum as well. Instead of running
Code:

apt-get install <package>
, you can run
Code:

yum install <package>


All times are GMT +2. The time now is 13:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.