HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=19)
-   -   HotSaNIC (http://www.howtoforge.com/forums/showthread.php?t=719)

domino 30th September 2005 19:53

HotSaNIC
 
HotSaNIC is a very nice tool which combines all sorts of very important system graphs into a simple and easy to understand webpage. It allows the admin to take a quick glance at the graphs to see what may or may not be working with the system. With the new APPS graph it is also possible to watch as more processes are started which can be helpful in tracking down why the server load is increasing. For instance if you see a huge load spike but you see that the number of exim processes has gone up significantly at the same time you can start to investigate.

I built this guide on a cPanel server but it will work fine on an ensim box as well. I don't recall the plesk mailserver off the top of my head but changing that small part will make it work great fine plesk.

How-To: http://www.eth0.us/hotsanic

Ovidiu 19th October 2005 10:40

thats an awesome howto - worked like a charm - I tried doing the same with mrtg - no chance for, but this just worked :-)

only one question remains: the howto was not for debian, so I think I can't apply the last part of it, when trying to get it to autostart with each reboot, can anyone help with that?

Ovidiu 23rd November 2005 15:21

anyone experienced in evaluating the output of the netstat module? After tweaking my apache settings I am seeing a lot of time_wait connections, an average of 188 but I don't know how to interpret it.

I know what it means, my apache2 child proc. waiting a certain period (I set that in the apache2 cfg) to see if the conection will be reused.

every how-to I found states that this should be done as a trade of between reusing connections and ram usage,...

anyone got more concrete suggestions? you can have a look at my current serverstats here: h**p://w*w.web-designerz.de/serverstats

!this is intentionally not a direct link!

domino 23rd November 2005 16:12

Hi,

I love graphs and yours looks really nice :D. Sorry I can't give feedback but I think www.webhostingtalk.com members might can enlighten you. They are pretty helpfull when they want to be. Just don't post the link to your graph or site unless you have it tided down.

heyp 4th December 2005 20:04

Hi,

i tried the tutorial, but with the newest version of rrdtool.

When i run ./diagrams.pl i get the following error:

PHP Code:

Cant locate RRDs.pm in @INC (@INC contains: ./platform ../../lib /etc/perl /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl /usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 .) at ../../lib/HotSaNICdiagram.pm line 7.
BEGIN failed
--compilation aborted at ../../lib/HotSaNICdiagram.pm line 7.
Compilation failed in 
require at ./diagrams.pl line 14. 

Any ideas? I've already read every FAQ on this without any help :(

Thx!

heyp 4th December 2005 20:30

Anyway, got it:

apt-get install librrds-perl solves the problem ;)

Ovidiu 5th December 2005 01:34

I would like to upgrade to latest rrdtool too but when doing ./configure I get libpng and freetype2 not found also both are installed on my system....
did you have to do any extra steps or did it just work?

I also updated to latest hotsanic version, (has more modules)

heyp 5th December 2005 09:19

Hi Tenaka,

if you go through the documentation on the rrdtool website, everything will run fine.

http://people.ee.ethz.ch/~oetiker/we...dbuild.en.html

HTH :)

Grizzly 14th March 2006 22:47

suse 10 ISPconfig
 
Quote:

Originally Posted by heyp
Hi Tenaka,

if you go through the documentation on the rrdtool website, everything will run fine.

http://people.ee.ethz.ch/~oetiker/we...dbuild.en.html

HTH :)

Would just like to know if this would also go for a suse 10 server with ispconfig, just got my server up and running. Thanks Falco & Till
(is it safe?)

falko 15th March 2006 01:16

I haven't tested, but I don't know why it shouldn't work. :)


All times are GMT +2. The time now is 02:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.