HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5) (http://www.howtoforge.com/forums/showthread.php?t=7073)

sneaky_russian 25th September 2006 20:15

Virtual Users And Domains With Postfix, Courier And MySQL (Fedora Core 5)
 
I have followed this guide step by step and have come across this problem.
I have formatted and started again and still get the same problem

If i telnet to the server i get this:
# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

In the error log i get this:
Sep 25 14:14:10 mail postfix/smtpd[17476]: fatal: no SASL authentication mechanisms
Sep 25 14:14:11 mail postfix/master[8082]: warning: process /usr/libexec/postfix/smtpd pid 17476 exit status 1
Sep 25 14:14:11 mail postfix/master[8082]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

anyone got any ideas as im pulling my hair out!

TIA

sneaky_russian 25th September 2006 20:33

ok figured it out

I didnt have cyrus-sasl-sql installed
although i cannot find any mention of this requirement on the guide

sneaky_russian 26th September 2006 00:13

ok i have come across another problem
i can send/receive email ok but its extremley slow and looking in the mail log im seeing this:

Sep 25 18:11:03 mail imapd: Failed to connect to socket /tmp/fam--
Sep 25 18:11:03 mail imapd: Failed to create cache file: maildirwatch (admin@xxxxxx.co.uk)
Sep 25 18:11:03 mail imapd: Error: Input/output error
Sep 25 18:11:03 mail imapd: Check for proper operation and configuration
Sep 25 18:11:03 mail imapd: of the File Access Monitor daemon (famd).

i got no idea what this means and how to fix it
any help appreciated

falko 26th September 2006 17:59

Quote:

Originally Posted by sneaky_russian
I didnt have cyrus-sasl-sql installed
although i cannot find any mention of this requirement on the guide

It isn't needed.

Please make sure that SELinux is disabled on your system.

sneaky_russian 26th September 2006 18:05

its not installed i already check that

well i given up on this one now and installed qmail with sql which runs very well so far - fingers crossed

thanks for your help anyway


All times are GMT +2. The time now is 20:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.