HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Changing servers hostname (http://www.howtoforge.com/forums/showthread.php?t=6868)

rbartz 15th September 2006 06:09

Changing servers hostname
 
Can you tell me the way to change a server's hostname so that everything works? It seems whatever I try, it creates a problem. The server is leased, when they installed Fedora Core 3, they assigned the server as 66-226-75-8.

We have about 15 domains on it now, but are having mail issues among other things. The mailog is full of warnings about the hostname not being FQDN, the hostname being numeric. It suggests naming the host in postfix/main.cf, but that causes all kinds of internal loop problems, as in thousands of undeliverable mail notices in a couple of mailboxes. :( Changing the hostname creates problems with local mail delivery too.

the output of hostname is:
==
66-226-75-8
==

the output of hostname -f (the place no doubt to begin!)
==
hostname: Unknown host
==

the /etc/sysconfig/network says:
==
NETWORKING=yes
HOSTNAME=66-226-75-8
GATEWAY=66.226.75.1
==

The /etc/hosts file says:
==
127.0.0.1 localhost.localdomain localhost
66.226.75.8 wvis2.net
66.226.75.8 66-226-75-8.dedicated.abac.net
==

wvis2.net is a FQDN that points to the server and is a domain installed with ispconfig

Finally, when I set the hostname to wvis2.net with
[root@66-226-75-8 etc]#hostname wvis2.net

and restart postfix, the warnings stop but postfix from then on bounces a lot of mail with this in the log:
==
Sep 14 19:07:48 66-226-75-8 postfix/smtp[3864]: A7A169543EA: to=<admispconfig@localhost.wvis2.net>, orig_to=<admispconfig@localhost>, relay=none, delay=0, status=bounced ([localhost.wvis2.net]: Name or service not known).

Thanks for helping me out on this.

RDB

==

rbartz 16th September 2006 07:16

Success...
 
I will answer myself :) in case anyone else has the same problem with a leased server:

1. in /etc/sysconfig/network set the hostname:

NETWORKING=yes
HOSTNAME=server.yourdomain.com
GATEWAY=66.226.75.1

2. In /etc/hosts set the ip with your new hostname

127.0.0.1 localhost.localdomain localhost
66.226.75.8 server.yourdomain.com
66.226.75.8 66-226-75-8.dedicated.abac.net

3. reboot

You do not need to change anything else in ispconfig, postfix, etc, all should come together on the reboot. Now the mail uses server.wvisw.net for hostname and spamassassin is happy and no loops and everything seems right.

till 16th September 2006 13:04

On some linux distributions you will have to chnage /etc/hostname too.

rbartz 16th September 2006 14:54

Yes, I see that. I had done that earlier in other attempts to bring this to some resolution, although I had not set it to the full server name I used.

Now, if I could just get suPHP to work I would have the "perfect server"... :-)

Thanks for the added advice Till.


All times are GMT +2. The time now is 11:21.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.