HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   VMWare install on Ubuntu problem with the IP (http://www.howtoforge.com/forums/showthread.php?t=6833)

velonis 13th September 2006 12:39

VMWare install on Ubuntu problem with the IP
 
I followed step by step the how-to for installing VMWare on Ubuntu. Everything went fine but there is a problem with the https://192.168.0.100:8333

Ofcourse my IP was 192.168.192.200 when I installed the VMWare and now I type https://192.168.192.200:8333 but it can't find anything.
From the command-line I typed vmware and the VMWare Server Consoled appeared and seems to work fine.

In the ifconfig's output I see vmnet1 192.168.78.1 and 172.16.246.1 . I tried these IPs but nothing.

How can I solve the IP problem?

till 13th September 2006 20:16

please post the output of:

netstat -tap

velonis 13th September 2006 21:17

Thank you for your reply. Without any browser open the output is:


Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:vmware-authd *:* LISTEN 5225/xinetd
tcp 0 0 localhost:submission *:* LISTEN 5559/sendmail: MTA:
tcp 0 0 localhost:49715 *:* LISTEN 4566/hpiod
tcp 0 0 localhost:ipp *:* LISTEN 4622/cupsd
tcp 0 0 localhost:smtp *:* LISTEN 5559/sendmail: MTA:
tcp 0 0 localhost:40285 *:* LISTEN 4572/python
tcp 1 114 192.168.192.200:39687 i01m-62-35:gnutella-svc CLOSING -
tcp 0 0 localhost:49715 localhost:56305 ESTABLISHED4566/hpiod
tcp 0 0 192.168.192.200:45315 72.14.205.83:https TIME_WAIT -
tcp 0 114 192.168.192.200:42647 cliente-10249.ibe:47860 FIN_WAIT1 -
tcp 0 0 192.168.192.200:35639 66.102.9.147:https TIME_WAIT -
tcp 0 0 192.168.192.200:35637 66.102.9.147:https TIME_WAIT -
tcp 0 0 192.168.192.200:50343 cm23032.red83-165:12121 TIME_WAIT -
tcp 1 169 192.168.192.200:45729 201-24-65-183.fnsc:4662 CLOSING -
tcp 0 0 192.168.192.200:50094 72.14.205.19:www TIME_WAIT -
tcp 0 0 192.168.192.200:50509 201-68-245-7.dsl.t:4662 TIME_WAIT -
tcp 0 0 localhost:56305 localhost:49715 ESTABLISHED4572/python
tcp 0 1 192.168.192.200:39160 201009080243.user:30820 FIN_WAIT1 -
tcp6 0 0 *:ssh *:* LISTEN 5190/sshd

falko 14th September 2006 19:52

Port 8333 is not in use, so the VMware management interface isn't started. What's the output of
Code:

ls -l /etc/init.d
?

velonis 15th September 2006 18:24

It is

-rwxr-xr-x 1 root root 2442 2005-09-15 21:30 acpid
-rwxr-xr-x 1 root root 867 2006-03-28 19:26 acpi-support
-rwxr-xr-x 1 root root 9282 2006-05-29 15:04 alsa-utils
-rwxr-xr-x 1 root root 1015 2005-05-03 05:08 anacron
-rwxr-xr-x 1 root root 1387 2006-05-09 00:45 atd
-rw------- 1 root root 3944 2005-11-05 17:50 bastille-firewall
-rwxr-xr-x 1 root root 2416 2006-01-19 01:11 bittorrent
-rwxr-xr-x 1 root root 5298 2006-03-20 07:52 bluez-utils
-rw-r--r-- 1 root root 2553 2006-05-23 13:40 bootclean.sh
-rwxr-xr-x 1 root root 1788 2006-05-23 13:40 bootlogd
-rwxr-xr-x 1 root root 2030 2006-05-23 13:40 bootmisc.sh
-rwxr-xr-x 1 root root 881 2006-04-20 12:30 brltty
-rwxr-xr-x 1 root root 1984 2006-05-23 13:40 checkfs.sh
-rwxr-xr-x 1 root root 8831 2006-05-23 13:40 checkroot.sh
-rwxr-xr-x 1 root root 3837 2006-05-14 14:32 clamav-daemon
-rwxr-xr-x 1 root root 5469 2006-05-14 14:34 clamav-freshclam
-rwxr-xr-x 1 root root 5979 2006-01-23 18:50 console-screen.sh
-rwxr-xr-x 1 root root 1739 2005-11-15 14:45 cron
-rwxr-xr-x 1 root root 1949 2006-08-03 11:53 cupsys
-rwxr-xr-x 1 root root 2557 2006-05-15 22:40 dbus
-rwxr-xr-x 1 root root 795 2006-02-23 18:37 dns-clean
-rwxr-xr-x 1 root root 923 2006-05-16 11:41 evms
-rwxr-xr-x 1 root root 1196 2006-05-21 17:44 festival
-rwxr-xr-x 1 root root 1567 2006-05-16 04:44 firestarter
-rwxr-xr-x 1 root root 2569 2006-08-02 17:08 gdm
-rwxr-xr-x 1 root root 6175 2006-05-21 20:25 glibc.sh
-rwxr-xr-x 1 root root 1404 2006-05-23 13:40 halt
-rwxr-xr-x 1 root root 5137 2005-04-21 13:10 hdparm
-rwxr-xr-x 1 root root 992 2006-05-23 13:40 hostname.sh
-rwxr-xr-x 1 root root 2245 2006-04-29 22:09 hotkey-setup
-rwxr-xr-x 1 root root 4213 2006-04-27 15:41 hplip

-rwxr-xr-x 1 root root 6947 2006-09-13 13:45 httpd.vmware

-rwxr-xr-x 1 root root 3634 2006-05-16 04:43 hwclock.sh
-rwxr-xr-x 1 root root 222 2006-09-05 19:01 inetd
-rwxr-xr-x 1 root root 3170 2005-11-25 22:30 keymap.sh
-rwxr-xr-x 1 root root 1840 2006-04-24 21:41 klogd
-rwxr-xr-x 1 root root 1153 2006-05-06 18:45 laptop-mode
-rwxr-xr-x 1 root root 349 2006-07-10 17:05 linux-restricted-modules-common
-rwxr-xr-x 1 root root 748 2006-01-23 20:47 loopback
-rwxr-xr-x 1 root root 2867 2005-11-08 10:30 lvm
-rwxr-xr-x 1 root root 822 2005-11-25 17:16 makedev
-rwxr-xr-x 1 root root 1124 2006-05-16 15:43 mdadm
-rwxr-xr-x 1 root root 1059 2006-05-16 15:43 mdadm-raid
-rwxr-xr-x 1 root root 921 2006-05-05 18:48 module-init-tools
-rwxr-xr-x 1 root root 2069 2006-05-23 13:40 mountall.sh
-rwxr-xr-x 1 root root 1256 2006-05-23 13:40 mountdevsubfs
-rwxr-xr-x 1 root root 1384 2006-05-23 13:40 mountvirtfs
-rwxr-xr-x 1 root root 2290 2006-05-23 13:40 mtab
-rwxr-xr-x 1 root root 1685 2006-05-11 09:54 networking
-rwxr-xr-x 1 root root 860 2005-10-29 05:48 nvidia-kernel
-rwxr-xr-x 1 root root 3386 2006-03-23 22:40 pcmciautils
-rwxr-xr-x 1 root root 3629 2006-05-08 20:46 powernowd
-rwxr-xr-x 1 root root 177 2006-05-08 20:46 powernowd.early
-rwxr-xr-x 1 root root 1061 2006-07-05 13:22 ppp
-rwxr-xr-x 1 root root 281 2006-07-05 13:22 pppd-dns
-rwxr-xr-x 1 root root 1234 2006-01-23 18:12 procps.sh
-rwxr-xr-x 1 root root 6897 2006-05-23 13:39 rc
-rwxr-xr-x 1 root root 522 2006-05-23 13:40 rc.local
-rwxr-xr-x 1 root root 188 2006-05-23 13:39 rcS
-rwxr-xr-x 1 root root 1424 2006-02-24 15:32 readahead
-rwxr-xr-x 1 root root 1883 2006-02-24 15:32 readahead-desktop
-rw-r--r-- 1 root root 866 2006-05-23 13:39 README
-rwxr-xr-x 1 root root 732 2006-05-23 13:40 reboot
-rwxr-xr-x 1 root root 1226 2006-05-23 13:40 rmnologin
-rwxr-xr-x 1 root root 2924 2006-05-05 17:42 rsync
-rwxr-xr-x 1 root root 452 2006-04-27 00:40 screen
-rwxr-xr-x 1 root root 30775 2006-03-23 16:47 sendmail
-rwxr-xr-x 1 root root 1081 2006-05-23 13:40 sendsigs
-rwxr-xr-x 1 root root 1126 2006-05-23 13:40 single
-rwxr-xr-x 1 root root 2679 2006-05-23 13:40 skeleton
-rwxr-xr-x 1 root root 2016 2006-05-18 03:41 ssh
lrwxrwxrwx 1 root root 8 2006-09-05 12:18 stop-bootlogd -> bootlogd
-rwxr-xr-x 1 root root 864 2006-02-24 15:32 stop-readahead
-rwxr-xr-x 1 root root 1669 2006-04-24 21:41 sysklogd
-rwxr-xr-x 1 root root 2539 2006-05-22 14:43 udev
-rwxr-xr-x 1 root root 1588 2006-05-23 13:40 umountfs
-rwxr-xr-x 1 root root 1989 2006-05-23 13:40 umountnfs.sh
-rwxr-xr-x 1 root root 912 2006-05-23 13:40 umountroot
-rwxr-xr-x 1 root root 1965 2006-05-23 13:40 urandom
-rwxr-xr-x 1 root root 2192 2006-02-23 05:50 usplash
-rwxr-xr-x 1 root root 820 2006-06-19 13:52 vbesave

-r-xr-xr-x 1 root root 20319 2006-09-13 13:13 vmware

-rwxr-xr-x 1 root root 1967 2006-05-23 13:40 waitnfs.sh
-rwxr-xr-x 1 root root 1091 2006-04-24 20:53 x11-common
-rwxr-xr-x 1 root root 1481 2006-01-19 18:16 xinetd

You can see the vmware and httpd.vmware

I typed
$sudo /etc/init.d/httpd.vmware status
vmware.httpd is not running.
$ sudo /etc/init.d/httpd.vmware start
Starting httpd.vmware: done
$ sudo /etc/init.d/httpd.vmware status
vmware.httpd is not running.

Ofcourse sudo vmware starts vmware with no problem (for now)
But if I run netstat -tap I get the same output as before.
As in the guide I ran the second script for VMWare MUI. I can see the /usr/lib/vmware-mui

falko 16th September 2006 23:42

Quote:

Originally Posted by velonis
I typed
$sudo /etc/init.d/httpd.vmware status
vmware.httpd is not running.
$ sudo /etc/init.d/httpd.vmware start
Starting httpd.vmware: done
$ sudo /etc/init.d/httpd.vmware status
vmware.httpd is not running.

Is there anything in your logs when this happens?

velonis 17th September 2006 21:09

I don't know in which log to search. Could you suggest ?

falko 18th September 2006 12:11

The logs are normally in the /var/log directory.

velonis 20th September 2006 10:55

There are the /var/log/vmware and /var/log/vmware-mui directories.

Yesterday after the kernel update (2.6.15-27) , I rerun the config scripts to recompile the modules and it run!
Today I have the same problem as before. In /var/log/vmware-mui/error_log I see the following -- that's the log for
sudo /etc/init.d/httpd.vmware start and
sudo /etc/init.d/httpd.vmware status


[Wed Sep 20 11:50:27 2006] [warn] pid file /var/run/httpd.vmware.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Sep 20 11:50:27 2006] [error] ModVmdb load: Address of ModVmdb_InitCore: 0x55c065a0\n
[Wed Sep 20 11:50:27 2006] [error] Failed to create named-pipe directory: /var/run/vmware//httpd/30782: \xce\x94\xce\xb5\xce\xbd \xcf\x85\xcf\x80\xce\xac\xcf\x81\xcf\x87\xce\xb5\x ce\xb9 \xcf\x84\xce\xad\xcf\x84\xce\xbf\xce\xb9\xce\xbf \xce\xb1\xcf\x81\xcf\x87\xce\xb5\xce\xaf\xce\xbf \xce\xae \xce\xba\xce\xb1\xcf\x84\xce\xac\xce\xbb\xce\xbf\x ce\xb3\xce\xbf\xcf\x82\n
[Wed Sep 20 11:50:27 2006] [error] VMWARE PANIC: \nNOT_IMPLEMENTED F(4023):707\n
[Wed Sep 20 11:50:27 2006] [error] Panic: Could not allocate temporary context.\n

velonis 21st September 2006 11:09

When the httpd.vmware run I had created a directory, the /var/run/vmware/httpd because somewhere in the log files there was a "there is no such file or directory"

The problem is that somehow this directory is erased .
The solution is

edit the /etc/init.d/httpd.vmware and immediately after "start)"
add the following code:

if [ ! -d /var/run/vmware/httpd ]
then
mkdir /var/run/vmware/httpd
chown www-data:nogroup /var/run/vmware/httpd
chmod 700 /var/run/vmware/httpd
fi


Found at:
http://www.vmware.com/community/thre...479166&#479166


All times are GMT +2. The time now is 03:28.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.