HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   email/ftp problem after moving ispconfig (http://www.howtoforge.com/forums/showthread.php?t=6831)

mystix 13th September 2006 12:42

email/ftp problem after moving ispconfig
 
email/ftp problem after moving ispconfig

Hello,

I moved ispconfig to a new server by copying /etc/passwd, /etc/shadow, /etc/group, Vhosts_ispconfig.conf, /etc/postfix/local-host-names, /etc/postfix/virtusertable, named.conf, the zone files, /etc/proftpd*.conf, /var/www/* the databases etc.

Now the sites a accessible again on the new server and the login to ispconfig works to.
But email an ftp users can't connect to the server.

I've copied the webusers in the original passwd, shadow and user files, but now there is a * and no encripted password ind /etc/shadow:

admispconfig:!:13401:0:99999:7:::
web35contact:*:13403:0:99999:7:::
web35www:*:13403:0:99999:7:::
web74admin:*:13403:0:99999:7:::

When I change the userpassword with ispconfig the * is replaced with the encripted password but i still can't login.

It would be nice I somebudy could help me!

thanks

Marc

till 13th September 2006 20:33

Have both servers the same linux distribution and use the same password encryption? have you copied the complete /etc/passw and /etc/shadow files or onyl the ISPConfig accounts starting with web....? Have you copied the gshadow file too, if this exists on your linux server?

mystix 13th September 2006 21:01

Quote:

Originally Posted by till
Have both servers the same linux distribution and use the same password encryption?

Yes both server have debian sarge installed.

Quote:

Originally Posted by till
have you copied the complete /etc/passw and /etc/shadow files or onyl the ISPConfig accounts starting with web....?

I've installed debian and ispconfig first, then i copied the part with the web* users into the /etc/passw and /etc/shadow file.

Quote:

Originally Posted by till
Have you copied the gshadow file too, if this exists on your linux server?

No i didn't copy that file but the file exists on the new server and the webusers are in the file.

marc

falko 14th September 2006 20:41

Does your new server use the old crypt passwords or the new MD5 passwords?


All times are GMT +2. The time now is 10:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.