HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   External mail server - Help please (http://www.howtoforge.com/forums/showthread.php?t=6808)

koalatelecom 12th September 2006 04:23

External mail server - Help please
 
Hello,

I managed to get the ispConfig all up and running.
However I have an issue with email.

The normail domains where mail is hosted on the ispConfig is fine.

However I have one email server that is very large load so I run a dedicated mail server.
I have the following in the DNS -

A Record
IP-Adresse Hostname
203.xxx.xxx.135 www
203.xxx.xxx.133 ns1
203.xxx.xxx.134 ns2
203.xxx.xxx.140 mail
202.xxx.xxx.15 news

MX
Mailserver Hostname
xxxxxx.com.au

---------------------

Under: Site -> Options
I have Mailserver = External mailserver
-- however it was originally set to internal (could this cause problems? Can I change later)

-----------------------

In co-domains tab I have
Domains
IP Hostname Domain
203.xxx.xxx.135 xxxxxx.com.au
When I click the IP i get another menu
I click the options tab and select "External mailserver"

However it appears the ispConfig is still trying to send/authenticate mail against its own mail server for this domain, not the external one.

Originally I setup the domain with local email, then changed it to external.
Is this causing a problem?
The DNS is a replica of what I had on my old BIND server.

Any help is appreciated...

Thanks

till 12th September 2006 12:17

Is the domian still listed in /etc(postfix/local-host-names ? Please check again that you have set the website and all co-domains of this website to external mailserver.

tijn_tux 25th January 2007 16:22

Hmm, i have the same problem, added a site for which we dont do the mail,

set it to 'external server' but it still apears in local-host-name

while an other domain has to mail a lot to the above mentioned but this doenst work, postfix tries to deliver the mail locally :(

tijn

till 25th January 2007 16:26

Quote:

Originally Posted by tijn_tux
Hmm, i have the same problem, added a site for which we dont do the mail,

set it to 'external server' but it still apears in local-host-name

while an other domain has to mail a lot to the above mentioned but this doenst work, postfix tries to deliver the mail locally :(

tijn

Did you set the co-domain to external mailserver too? You will have to set it at lesat in 2 places to external mailserver!

tijn_tux 25th January 2007 16:29

Works! till, you are my hero :D

Thnx m8!

tijn:D


All times are GMT +2. The time now is 08:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.