HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   ISPConfig not reponding (http://www.howtoforge.com/forums/showthread.php?t=6764)

fbnewtz 10th September 2006 05:29

ISPConfig not reponding
 
When I try to visit my website at https://www.mydomain.com:81 I never get a response. ISPConfig is running in the background. When I try and set something else to listen on that port (ie. Setup my main apache to listen on port 81) it tells me the port is already being used.

Here is my output from netstat -a |grep 81

Code:

netstat -a |grep 81
tcp        0      0 *:81                    *:*                    LISTEN
unix  2      [ ACC ]    STREAM    LISTENING    80181    private/error
unix  2      [ ]        DGRAM                    83081

Here is my output from ps aux:
Code:

root    28231  0.0  3.0 12268 7728 ?        Ss  15:09  0:00 /root/ispconfig/httpd/bin/ispconfig_httpd -DSSL
root    28232  0.0  0.4  2708 1252 pts/0    S    15:09  0:00 /bin/bash /root/ispconfig/sv/ispconfig_wconf
admispc  28246  0.0  3.0 12268 7732 ?        S    15:09  0:00 /root/ispconfig/httpd/bin/ispconfig_httpd -DSSL
root    28253  0.0  4.4 57972 11416 ?      Ss  15:09  0:00 /usr/sbin/apache2 -k start -DSSL
root    28254  0.0  0.1  1616  424 ?        S    15:09  0:00 /root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig
www-data 28255  0.0  2.4 14828 6372 ?        S    15:09  0:00 /usr/sbin/fcgi-pm -k start -DSSL
www-data 28308  0.0  4.4 57972 11504 ?      S    15:09  0:00 /usr/sbin/apache2 -k start -DSSL
www-data 28309  0.0  4.4 57972 11504 ?      S    15:09  0:00 /usr/sbin/apache2 -k start -DSSL
www-data 28310  0.0  4.5 57972 11572 ?      S    15:09  0:00 /usr/sbin/apache2 -k start -DSSL
www-data 28311  0.0  4.5 57972 11556 ?      S    15:09  0:00 /usr/sbin/apache2 -k start -DSSL
www-data 28312  0.0  4.5 57972 11520 ?      S    15:09  0:00 /usr/sbin/apache2 -k start -DSSL

Of course there is quite a bit more, but that is the stuff that looked important.

Please let me know if there is anything else I can provide to help figure this out.

Thanks,

Fred

Ben 10th September 2006 13:15

What does
netstat -tap
show which process is running on port 81?

Have you tried restarting ispconfig_httpd?

Does a wget / curl / lynx https://localhost:81 work?

Can you see anything in the ISPConfig's apache error / access logs?

till 10th September 2006 14:27

Please post the output of the following command too:

iptables -L

I guess you blocked port 81 with a firewall.


All times are GMT +2. The time now is 23:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.