HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs (http://www.howtoforge.com/forums/showthread.php?t=6751)

hdtpsi 9th September 2006 10:06

Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs
 
Cant send test email with amavisd installed
log output /var/log/mail.log

Sep 10 03:38:38 mythserver amavis[17804]: (17804-03) mail_via_smtp: 450 4.4.1 Can't connect to 127.0.0.1 port 10024, Operation now in progress at /usr/sbin/amavisd-new line 2912, <GEN9> line 200., id=17804-03
Sep 10 03:38:38 mythserver amavis[17804]: (17804-03) Not-Delivered, <test@workaround.org> -> <dave@mythtv.net>, Message-ID: <20060909164817.3A58A6F0A6@mythserver.mythtv.net >, Hits: -0.137
Sep 10 03:38:38 mythserver amavis[17806]: (17806-04) Warning: sending SMTP QUIT command failed: 450 4.4.1 Can't connect to 127.0.0.1 port 10024, Operation now in progress at /usr/sbin/amavisd-new line 2912, <GEN9> line 200., id=17804-03\n
Sep 10 03:38:38 mythserver amavis[17806]: (17806-04) mail_via_smtp: 451 4.6.0 Bad SMTP code, id=17806-04, from MTA: "354 End data with <CR><LF>.<CR><LF>"
Sep 10 03:38:38 mythserver amavis[17806]: (17806-04) Not-Delivered, <test@workaround.org> -> <dave@mythtv.net>, Message-ID: <20060909164817.3A58A6F0A6@mythserver.mythtv.net >, Hits: -0.136
Sep 10 03:38:38 mythserver amavis[17805]: (17805-03) Warning: sending SMTP QUIT command failed: 451 4.6.0 Bad SMTP code, id=17806-04, from MTA: "354 End data with <CR><LF>.<CR><LF>"\n
Sep 10 03:38:38 mythserver amavis[17805]: (17805-03) mail_via_smtp: 451 4.6.0 Bad SMTP code, id=17805-03, from MTA: "354 End data with <CR><LF>.<CR><LF>"
Sep 10 03:38:38 mythserver amavis[17805]: (17805-03) Not-Delivered, <test@workaround.org> -> <dave@mythtv.net>, Message-ID: <20060909164817.3A58A6F0A6@mythserver.mythtv.net >, Hits: -0.136
Sep 10 03:38:38 mythserver amavis[17807]: (17807-04) Warning: sending SMTP QUIT command failed: 451 4.6.0 Bad SMTP code, id=17805-03, from MTA: "354 End data with <CR><LF>.<CR><LF>"\n
Sep 10 03:38:38 mythserver amavis[17807]: (17807-04) mail_via_smtp: 451 4.6.0 Bad SMTP code, id=17807-04, from MTA: "354 End data with <CR><LF>.<CR><LF>"
Sep 10 03:38:38 mythserver amavis[17807]: (17807-04) Not-Delivered, <test@workaround.org> -> <dave@mythtv.net>, Message-ID: <20060909164817.3A58A6F0A6@mythserver.mythtv.net >, Hits: -0.135
Sep 10 03:38:38 mythserver postfix/smtp[18829]: 3A58A6F0A6: to=<dave@mythtv.net>, relay=127.0.0.1[127.0.0.1], delay=3021, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.6.0 Bad SMTP code, id=17807-04, from MTA: "354 End data with <CR><LF>.<CR><LF>" (in reply to end of DATA command))

falko 10th September 2006 19:22

Quote:

Originally Posted by hdtpsi
Cant send test email with amavisd installed
log output /var/log/mail.log

Sep 10 03:38:38 mythserver amavis[17804]: (17804-03) mail_via_smtp: 450 4.4.1 Can't connect to 127.0.0.1 port 10024, Operation now in progress at /usr/sbin/amavisd-new line 2912, <GEN9> line 200., id=17804-03

What's the output of
Code:

netstat -tap
?

hdtpsi 16th September 2006 05:44

Pop3 access
 
Amavis is working Fine now just used apt to remove and reinstall it seems to be fine now i can send and recieve messages with telnet and can forward from client software on the localhost (thunderbird but it doesnt like smtp-auth) but pop3 access is refused all the time with login-refused from server.
Can telnet pop3 it seems to be responding OK but no access.

falko 17th September 2006 13:31

What's the exact error message? Any errors in your log files?

hdtpsi 18th September 2006 16:02

Here is the log /var/log/mail.log
 
Sep 18 23:53:30 mythserver courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Sep 18 23:53:41 mythserver courierpop3login: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Sep 18 23:54:11 mythserver last message repeated 2 times

falko 19th September 2006 15:18

Are you sure you use the correct username (must be an email address!) and password?

Anne_Kleyheeg 23rd September 2006 00:43

Maildir
 
I've compleet the configuration and it works.
But is get 1 error:
chdir ansmeijlink.nl/root/: No such file or directory
This is because the Maildir map doesn't excist.
Must i create it or have i done something wrong.
And where must i create the Maildir

hdtpsi 23rd September 2006 23:57

I am using email for username and correct password ofcourse but i think mysql is not bind to 127.0.0.1 what are the dissadvantages of running your mysql srcipts with host = localhost or how to fix mysql issue

hdtpsi 24th September 2006 09:23

When i add bind-address = 127.0.0.1 to /etc/mysql/my.cnf the machine crashes
It is a Knoppmyth R5C7 distro of debian sarge

falko 24th September 2006 13:51

Quote:

Originally Posted by Anne_Kleyheeg
I've compleet the configuration and it works.
But is get 1 error:
chdir ansmeijlink.nl/root/: No such file or directory
This is because the Maildir map doesn't excist.
Must i create it or have i done something wrong.
And where must i create the Maildir

You must send a mail first to that user. The Maildir is created when the first mail arrives.


All times are GMT +2. The time now is 20:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.