HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   Installation/Configuration (
-   -   SSL Certificate configuration (

main3 9th September 2006 08:14

SSL Certificate configuration
Ok I just registered and SSL with

Now I received 2 files.


I downloaded those files into the SSL folder in www/ssl. When I connect to the site using I get this error.

It seems to work fine with FireFox
How ever with IE I get this error.

There is a problem with this website's security certificate.

Can some one tell how to proceed and what file should I change or where should I add these certificats

Thank you

Hans 9th September 2006 09:52

I have seen that you fixed it already.
When i visit your site i have no errors with any browser.

Nevertheless, i like to give this info as well:

If you want to use a SSL certificate for a web on your server:

Whithin ISPConfig, on the basic tab of the website which needs SSL, you enable SSL.
Then click on the options of that site and then on the SSL tab.
There, you can put your certifate for your website.
(One certificate / IP).

main3 9th September 2006 18:10

No Still not working
Make sure you test with this link.

main3 9th September 2006 19:32

SLL picking up a fake one some where in ispconfig
This is the one it is picking up see image.

falko 10th September 2006 20:19

The Common Name in the certificate isn't correct. It's www.snakeoil.dom, but it should be

main3 10th September 2006 21:52

This is weird it seems to be picking up some other SSL certificat and not my falide one. I am not sure if this files is in some other folder. Do you have any ideas to fixe this.

till 11th September 2006 10:56

Did you insert the SSL certificate in the correct filed in ISPConfig on the SSL tab of the website and select save as action?

main3 12th September 2006 01:40

Not sure on SLL
I am not sure on that one.

Their is 2 feilds.
SSL Request and SSL Certificate

I received 2 files

Not sure what goes where.

How ever this is what I did.

Content of sf_issuig.crt was put in SSL Request
Content of was put in SSL Certificate

Is this the right step.

Thank you

till 12th September 2006 13:05

You must put the content of in the SSL-Certificate field. Do not change the SSL-Request field.

falko 12th September 2006 16:46

Also have a look here:

All times are GMT +2. The time now is 08:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.