HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   mysql password during installation (http://www.howtoforge.com/forums/showthread.php?t=626)

Hellbound 21st September 2005 11:59

mysql password during installation
 
hi guys
my first installation of ispconfig failed however the /home/admispconfig is exist which seems to be incompleted, at least its missing spamassasin,

anyhow I tried to re-install the ispconfig and it doesn't ask the mysql password second time as I can't re-enter the installaiton will lead to failure as below.

I'm a total newbie in linux enviroment so may be something very simple for you.

thanks

Code:

########## INSTALLATION ##########

Preparing files. Please wait a moment...
cp: cannot stat `/home/admispconfig/ispconfig/lib/config.inc.php': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/users': No such file or directory
cp: cannot stat `/home/admispconfig/ispconfig/adminmail.txt': No such file or directory
All prerequisites are fulfilled.
Here we go...


Warning: main(config.inc.php): failed to open stream: No such file or directory in /home/mohd/install_ispconfig/install.php on line 624

Warning: main(): Failed opening 'config.inc.php' for inclusion (include_path='.:/root/ispconfig/php/lib/php') in /home/mohd/install_ispconfig/install.php on line 624

Warning: mysql_connect(): Access denied for user 'root'@'localhost' (using password: NO) in /home/mohd/install_ispconfig/install.php on line 634
Could not connect to db
Restarting some services...
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs
./setup2: line 883: [: ==: unary operator expected
./setup2: line 901: /etc/rc.d/init.d/ispconfig_server: No such file or directory
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

[root@host install_ispconfig]#


till 21st September 2005 12:07

Before you can reinstall ISPConfig, you must delete the failed installation parts.

rm -rf /root/ispconfig
rm -rf /home/admispconfig

The unpack the installer tar.gz file again and run the setup script.

Hellbound 21st September 2005 12:10

thanks dude,
will do now.

c0d3x42 21st September 2005 18:47

password not accepted
 
I had a similar problem, and re-installing did not help. In the end i had to temporarily set the mysql root users password to an empty string. Then i started the install from scratch again and it worked fine.

FYI, the neccessary SQL on my Debian/sarge box was:

update user set password='' where user='root' and host='localhost';
flush privileges;
I would recommend setting this back to a sane and secure value afterwards. You'll also need to edit the ispconfig files to reflect this change.

Hellbound 21st September 2005 18:52

thanks dude
the issue was solved after deleting those two folder, ispconfig is runing now :)

thanks.


All times are GMT +2. The time now is 14:11.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.