HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   ISPConfig 3 Priority Support (http://www.howtoforge.com/forums/forumdisplay.php?f=35)
-   -   unable to connect via SFTP (http://www.howtoforge.com/forums/showthread.php?t=62523)

aldo 12th July 2013 17:21

unable to connect via SFTP
 
I just installed ISPConfig 3.0.5.2 on Debian 7 and no user can connect via SFTP.

Shell users (all Jailed) are correct because they can connect via SSH.

Using FileZilla SFTP I get:
Connection closed by server with exut code 1

Using Bitvise Tunnelier SFTP I get:
Opening new SFTP session
Closing SFTP session.

Using Bitvise Tunnelier SSH I can connect normally.

Thanks for any help.

till 12th July 2013 20:44

Please see here for instructions to enable sftp for jailed users:

http://symka.blogspot.de/2013/05/jai...1204-sftp.html

The guide is for ubuntu but it should work for debian 7 as well.

aldo 13th July 2013 02:31

Sorry, not solved.

I modified the file /etc/jailkit/jk_init.ini (I have no jk.init.ini) as described and restarted fail2ban (/etc/init.d/fail2ban restart) with no luck.

I noticed that setting "Chroot shell" to "none" the accounts can connect but I need them to be jailed.

Croydon 13th July 2013 17:06

Have you tested with a newly created shell user? I think the changes do not apply to already existing users.

aldo 14th July 2013 10:39

Yes.

I deleted old users and re-created.

aldo 14th July 2013 12:25

In /var/log/auth.log I can only see:

Code:

Jul 14 12:36:16 debian7 sshd[5601]: Accepted password for ngtest from 192.168.1.100 port 57656 ssh2
Jul 14 12:36:16 debian7 sshd[5601]: pam_unix(sshd:session): session opened for user ngtest by (uid=0)
Jul 14 12:36:16 debian7 sshd[5603]: subsystem request for sftp by user ngtest
Jul 14 12:36:16 debian7 jk_chrootsh[5608]: now entering jail /var/www/clients/client1/web2 for user ngtest (5005) with arguments -c /usr/lib/openssh/sftp-server
Jul 14 12:36:16 debian7 sshd[5601]: pam_unix(sshd:session): session closed for user ngtest

Any idea?

Croydon 14th July 2013 18:48

I meant creating one that did not exist before (and was deleted). Did you try this?

aldo 14th July 2013 21:14

Yes, I tried both, to re-create existing users and also to create new users but without success.

Now I tried to create a new client, a new website and a new shell user and this time it works. Thank you.

Is there a way to fix the existing sites/user or I have to re-create them?

Thank you very much.

Croydon 14th July 2013 21:25

I'm not exactly sure. You could try using the command line tool jk_cp

Something like
jk_cp -j /var/www/clients/clientX/webY/./home/userxyz /lib/x86_64-linux-gnu/libnsl.so.1 /lib/x86_64-linux-gnu/libnss*.so.2


Edit: maybe
jk_update -j /var/www/clients/clientX/webY/./home/userxyz
could work, too. I have not tried.


All times are GMT +2. The time now is 13:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.