HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=25)
-   -   ISPCOnfig Weird/Blank page (http://www.howtoforge.com/forums/showthread.php?t=62517)

tresloukadu 12th July 2013 08:18

ISPCOnfig Weird/Blank page
 
1 Attachment(s)
Hello, after installing the ispconfig3 following this article:

http://www.howtoforge.com/perfect-se...ispconfig-3-p6


I got a problem. My ispconfig just shows:

Skip to the navigation. Skip to the content.
ISPConfig 3

hosting control panel



Powered by ISPConfig

Just that nothing more. Anybody could give a hand?

Croydon 12th July 2013 11:00

It seems that CSS styles are not loaded.
Have you tried a different browser?

tresloukadu 12th July 2013 14:47

Yes I tried Firefox and Chrome. I think is more than a css issue because even the links are not appearing.

Looking the ispconfig install log i found 3 warnings, but i think the blank page problem was not generated by these warnings....

Fri Jul 12 02:48:23 BRT 2013 - [ISPConfig] - /tmp/ispconfig3_install/install/dist/lib/opensuse.lib.php, Line 1039: WARNING: Failed to execute the command groupmod --add-user wwwrun ispconfig
Fri Jul 12 02:48:23 BRT 2013 - [ISPConfig] - /tmp/ispconfig3_install/install/dist/lib/opensuse.lib.php, Line 1042: WARNING: Failed to execute the command groupmod --add-user wwwrun ispapps


Fri Jul 12 02:47:12 BRT 2013 - [ISPConfig] - /tmp/ispconfig3_install/install/lib/installer_base.lib.php, Line 1489: WARNING: Failed to execute the command adduser wwwrun ispapps

Croydon 12th July 2013 14:57

The image you posted is exactly what appears when you have CSS and javascript disabled. I just checked this at my installation (disabled js and css through web developer extension) and it looks exactly the same as yours.

tresloukadu 12th July 2013 15:09

Well, I do not have plugins to block css and js, just to ensure i opened in a different machine and i got the same issue....

But trying to tracking what you have reported i just looked over the code and found something interesting, i tried to access some of the css and js files bellow and i got 404 error page not found for alll files listeed here...... im just in doubt how to fix it .... if i have to edit code or whatever.....

<link href="themes/default/css/styles.css" rel="stylesheet" media="screen" type="text/css" />
<link href="themes/default/css/print.css" rel="stylesheet" media="print" type="text/css" />
<!--[if IE 9]><link href="themes/default/css/iehacks.css" rel="stylesheet" type="text/css" /><![endif]-->
<!--[if lte IE 8]><script type="text/javascript" src="themes/default/js/html5shiv.js"></script><![endif]-->
<!--[if lte IE 7]><link href="themes/default/css/iehacks.css" rel="stylesheet" type="text/css" /><![endif]-->
<link href="themes/default/css/jquery-ui-1.8.16.custom.css" rel="stylesheet" type="text/css" />
<link rel="shortcut icon" href="/themes/default/images/favicon.ico" />
<script type="text/javascript" src="js/jquery-1.6.3.min.js"></script>
<script type="text/javascript" src="js/jquery-ui-1.8.16.custom.min.js"></script>
<script type="text/javascript" src="js/scrigo.js.php"></script>
<script type="text/javascript" src="js/uni-form/uni-form.jquery.js"></script>
<script type="text/javascript" src="js/jquery.ispconfigsearch.js"></script>
<script type="text/javascript" src="js/jquery.tipsy.js"></script>

Croydon 12th July 2013 15:45

Quite strange, indeed.
Have you tried doing an ispconfig update (with the same version)?
This should copy all needed files in place.

tresloukadu 12th July 2013 16:06

No success with that:

BilboBaggins:~ # ispconfig_update.sh

I chose to install stable, no updated you are running the lastet version.

O i tried again and now I chose to install the svn version.... after update and apache restart... i got the same issue.

I think I gonna unnistall everything and install a version bellow the 3.0.5.2. what you think?

Croydon 12th July 2013 16:11

Thats really strange.

Did you have a look into /usr/local/ispconfig/interface/web
if the "missing" files like js/jquery..... themes/default/css/styles.css etc are really missing or just are not displayed?

tresloukadu 12th July 2013 16:20

yes i've tried that and all files are there....css js, jquery.... i was thinking about change the theme manually

Croydon 12th July 2013 16:35

Hm, I'm out of ideas at the moment. Maybe someone else can help?


All times are GMT +2. The time now is 05:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.