HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   problem implementing wildcard SSL (http://www.howtoforge.com/forums/showthread.php?t=62433)

abubin 3rd July 2013 12:08

problem implementing wildcard SSL
 
i am having problem getting wildcard SSL to work in ispconfig.

I have followed some guide in this forum on implementing pre-configured SSL but it still doesn't work.

Getting error
Code:

Secure Connection Failed

          An error occurred during a connection to domain.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

I even tried to manually configure the SSL but it doesn't work.

I am using ubuntu 10.04LTS.

I have ispconfig gui running in self-created SSL cert. Could this be the reason for the problem? Perhaps I should disable SSL in ispconfig gui and then try to configure the website again to use SSL?

Would really appreciate help from the pros here.

more errors from apache logs:
Quote:

[Wed Jul 03 15:58:03 2013] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Quote:

[Wed Jul 03 15:58:03 2013] [warn] RSA server certificate wildcard CommonName (CN) `*.domain.com' does NOT match server name!?
thanks.

abubin 9th July 2013 10:06

no solution for this?

till 9th July 2013 11:10

The ssl key is not matching the ssl cert. If you install a ssl cert were the csr was created outside of ispconfig, you will have to replace the ssl key generated by ispconfig with the ssl key that you created outside of ispconfig for this certificate.


All times are GMT +2. The time now is 18:17.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.