HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   client denied by server configuration | File does not exist: /etc/apache2/htdocs (http://www.howtoforge.com/forums/showthread.php?t=62424)

masoodmx 2nd July 2013 13:13

client denied by server configuration | File does not exist: /etc/apache2/htdocs
 
I've been tackling with a problem in the apache server of our company for many hours; It's quite urgent and couldn't resolve it yet!

Actually the website of the company runs a shell script file providing pre-download information and download link in which some HTML code is embedded.

After installing a tool called awstats, some configuration modification was needed, and I tried any possible option to successfully run, but unfortunately couldn't. But the main and important problem now is that there is an error of permission denied, when the script file should be run!

This is the error shown in the page:

Forbidden

You don't have permission to access /programName/ on this server.
Apache/2.2.22 (Ubuntu) Server at companyWebsite.de Port 80

In addition, the following error logs exist in error.log file:

client denied by server configuration: /var/www/programName/programName.sh, referer: http://companyWebsite.de/companyName...Name_Downloads

File does not exist: /etc/apache2/htdocs

There is not htdocs in this directory.
The file httpd.conf is empty.
And the content of conf.d/programName.conf is:

Alias /programName /var/www/programName

<Directory /var/www/programName>
Options +ExecCGI
AddHandler cgi-script .sh
DirectoryIndex programName.sh
Order allow,deny
Allow from All
</Directory>
Also, according to [this related topic][1] , the code "Require all granted" doesn't work!

The file site-availabe/default is the same as default file offered everywhere. But site-available/companyName configuration file has the following content:

<VirtualHost *:80>
ServerAdmin edv@companyName.selfip.com
DocumentRoot /var/www
Options -Indexes
ErrorLog /var/log/apache2/error.log

LogLevel warn

CustomLog /var/log/apache2/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>
</VirtualHost>

If there is more information needed to solve the issue, just let me know please.

Thanks in advance.


[1]: http://stackoverflow.com/questions/1...-configuration


All times are GMT +2. The time now is 20:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.