HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=27)
-   -   No logon (http://www.howtoforge.com/forums/showthread.php?t=62346)

madmac007 24th June 2013 04:31

No logon
 
Hi all,

new fresh install
SuSe 12.2, from here:
The Perfect Server - OpenSUSE 12.2 x86_64 (Apache2, Dovecot, ISPConfig 3)
http://www.howtoforge.com/perfect-se...ot-ispconfig-3

All well no errors.
INstalled ISPconfig 3, standad install no errors etc etc.

However
https://myipadderss:8080

All I get is this:
Skip to the navigation. Skip to the content.
ISPConfig 3
hosting control panel
Powered by ISPConfig

No login screen
Please advise

madmac

till 25th June 2013 09:23

Check the apache error.log for errors.

madmac007 25th June 2013 16:12

will do
 
will do, thanks Till,

I will post back later today my findings.

madmac

madmac007 26th June 2013 00:09

no access
 
in the logs
/var/log/apache2/error.log

hundreds of this:
Sun Jun 23 19:35:01 2013] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/

And ever more of this:
(13)Permission denied: file permissions deny server access: (13)Permission denied: file permissions deny server access: /srv/www/ispconfig/themes/default/images/header_logo.png, referer: https://myipaddress:8080/
More like that, the entry after /srv/www/ispconfig/ other directories etc

What permissions should the folders and files be.

Thanks

madmac007 26th June 2013 00:20

Same
 
Found same question here, but no correct answer
http://www.howtoforge.com/forums/showthread.php?t=61649

I will no make the dir 777

madmac

madmac007 26th June 2013 23:36

Help
 
Any Ideas what the permissions should be please for files and folders:

I can run thses commandes to fix, by need to know
what settingd and what owner

eg:
find /full/path/to/directory/ -type d -print0 | xargs -I {} -0 chmod 0755 {}

find /full/path/to/directory/ -type f -print0 | xargs -I {} -0 chmod 0644 {}

Thanks
FYI does this only happen with SuSe 12.2 install?

madmac007 4th July 2013 22:54

Still NOgo
 
Hi all,

I think there has to be a problem on the Suse Install Or the ispconfig 3 installer for Suse 12.x

I created on a New different PC A SuSe install ( 12.2 )
The Perfect Server - OpenSUSE 12.2 x86_64 (Apache2, Dovecot, ISPConfig 3)
http://www.howtoforge.com/perfect-se...ot-ispconfig-3

I still get the same as before , no logon ( see above post )

However, I did run
chmod -R 775 /srv/www/ispconfig

And I do get the admin login screen now.

I ask again, what should the correct Permissions be on the files and folders ?

florian030 5th July 2013 07:08

On OpenSuSE 11.4 i have 751 for all files and directories. I think 750 should be enough.

madmac007 10th July 2013 02:48

Thanks
 
On my SuSe 12.2 install
had to set chmod -R 775 /srv/www/ispconfig
Now it works.

Danke florian030
Thanks All.

madmac


All times are GMT +2. The time now is 19:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.