HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Odd error in Apache2 logs - Ubuntu 12.04 (http://www.howtoforge.com/forums/showthread.php?t=62327)

medicMe 23rd June 2013 01:03

Odd error in Apache2 logs - Ubuntu 12.04
 
I got an entry in apache's error.log that has me confused.

The server gets hit with random file not found errors like most any web server would (script kiddies looking for admin pages for web apps that aren't even installed and the like.. standard stuff.)

But then I saw a file not found error for a file that does exist, a web page that gets hit often since it pulls in the most organic search traffic.

At first I figured someone typo'd the URL when entering it in manually, but it checks out fine, letter for letter..

And I double checked the page, it loads fine now.

So, it seems for one moment, my Apache server thought a file that is legit and regularly accessed, no longer existed.

What happened? Is this common? Does Apache log anything else that could shed more light on what happened?

I reviewed the requesting IP address's instances in Apache's access.log and it appears the only request that IP ever made was the single line that resulted in 404ing.. so it doesn't appear like it was a script hitting everything on the site, it was very specific and the user bounced after getting my 404 page. :/

mzandstra 23rd June 2013 22:03

Details Please
 
Can you post the relevant lines of the log files, the urls, etc.?

Initial thoughts:

Relative vs. absolute path issue
www vs non-www
CMS-specific permissions

I may have some other thoughts after seeing your logfiles.


All times are GMT +2. The time now is 08:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.