HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   ISPConfig 3 Priority Support (http://www.howtoforge.com/forums/forumdisplay.php?f=35)
-   -   All sites return the default page (http://www.howtoforge.com/forums/showthread.php?t=62308)

cafeine65 21st June 2013 10:46

All sites return the default page
 
this morning I found that all of my sites back my page default ISP Config "Welcome to your website".
I have make not made ​​changes since a couple of day, and yesteday all was ok. If I call directly a php page or txt me for example nginx returns 404
an idea ?

cafeine65 21st June 2013 11:22

Verry strange on only one site I have for the ip address not * but the real ip of my server. If i put * it's work fine, if I put the real ip of the server I have the problem.

till 21st June 2013 11:41

Dont mix * and IP address in the website settings for sites that point to the same IP. If you mix them, apache will show the site were you selected the IP address as a IP is a stronger match then *. In that case, use either * for all sites or the IP address for all sites.

Another thing regarding IP addresses, if your server is behind a router and you want to use a IP address instead of *, then you have to use the internal IP address and not the external one.


All times are GMT +2. The time now is 11:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.